Simple android emulation not working


#1

Anyone have any suggestions for how I can get responses in this forum on this issue?
Maybe there is a better place to post this like on github?

I am new to meteor and have been wrestling with getting the tutorial, as well as the default app to run in the android emulator.
I am running linux under virtualbox.
I have tried on both ubuntu 14.04 and 15.04 using the oracle jvm.
I have gotten the entire process to work with the emulator running android fine, but the test app does not appear to get run even though --verbose seems to indicate it should be. All I end up seeing is the android home page or the lock screen.

The app is just the default created app…
$ meteor create testapp
$ cd testapp
testapp$

Here are the last few lines of output when running…

testapp$ meteor run --verbose android

BUILD SUCCESSFUL
Total time: 9 seconds
Built the following apk(s):
/meteor/testapp/.meteor/local/cordova-build/platforms/android/ant-build/CordovaApp-debug.apk
Installing app on emulator…
Using apk: /meteor/testapp/.meteor/local/cordova-build/platforms/android/ant-build/CordovaApp-debug.apk
Launching application…
LAUNCH SUCCESS
Command finished with error code 0: /meteor/testapp/.meteor/local/cordova-build/platforms/android/cordova/run --emulator

Can someone tell me whether what I am supposed to end up seeing is the android homepage, or does the above show the running app for other people?
Can anybody else get the default app to show up in the emulator?
There is a big discussion on why meteor adoption is so slow, and not being able to get emulation working in what appears to be its most simple form could definitely be a contributing factor…


#2

Well, since I was unable to get any answers on this, I ended up having to figure it out myself, and so I will pass on this information, both as an aid, and as a bug report.

I have tried the following configurations:
Ubuntu 15.04 VM running under Windows virtualbox 4.3.30
Ubuntu 14.04 VM running under Windows virtualbox 4.3.30
Ubuntu 15.04 as base OS with KVM turned off in bios
Ubuntu 15.04 as base OS with KVM supported in bios

The only one that works is running base OS with KVM support turned on.
In any of the other configurations, the app fails to get loaded onto the emulator, no matter how long you wait, and all you get is the default android system.

If, however, you start up an emulator manually using avd:

apt-get install android-tools-adb
android avd

and then load the apk generated by meteor:

adb install testapp/.meteor/local/cordova-build/platforms/android/ant-build/CordovaApp-debug.apk

The testapp icon shows up in the list of apps on the phone, but when you run it, you see the meteor splash screen, followed by a blank white screen (presumably the white background of the default app), rather than the default app that shows how many times you pressed the button. This acted identically on all 3 configurations without physical CPU supported KVM. The same process with KVM support enabled, had the exact same experience, except the screen shows white with the full app running correctly, and you can hit the button, etc.

So I guess the bottom line is that Android emulation of Meteor apps DOES NOT currently work in virtualized environments, or with KVM turned off.