Simple todo list: Starting app on Android Device

Hi all,

I’m trying to compile the simple todos app on Ubuntu (WSL) for the first time. Getting a few warnings but it seems to be doing something at least. The last message says “Starting app on Android Device”. Its been doing this for over an hour now.

Should I just let this run or is there something that I need to address first?

Ok, chances are your device is not connected. Did you check whether a device is available by running adb devices?
It should look similar to the attached photo.
The easiest way to attach a device is to go into de Developer settings on the phone (I presume you use a physical device) and enable WIFI debugging.

Once a device is attached and installed you should be able to debug it with a Chrome browser ( at url: chrome://inspect/#devices)
Screen Shot 2022-07-14 at 6.20.50 PM

I’ve been trying various things. I’ve got USB and Wireless debugging enabled at the moment.

Using Powershell I’ve got this:

When I run adb devices on Ubuntu I get a blank line, so clearly not connected.

When I look at my Wireless debugging settings I see:

IP address and port:

Paired devices:

On Chrome I see:

I might be getting somewhere with this.

I enter adb devices and get this:

List of devices attached
FJOD3043FPO unauthorized

When I run adb -d logcat -c the following is displayed:

- waiting for device -

The device doesn’t show up.

Now have this fixed! My Simple Todo list app even installed on my phone too! Feel like a deserve a medal for today’s headaches!

I ran adb devices again and got this:

List of devices attached
FJOD3043FPO device

It seems that after some trial and error the solution was to use adb from windows and create a symlink to adb in Ubuntu, like so:

sudo ln -s /mnt/c/Users/44739/Downloads/platform-tools_r33.0.2-windows-adb/platform-tools/adb.exe /etc/Android/Sdk/platform-tools/adb

I decided to restart my phone and when it restarted I was prompted with an authorisation message for USB Debugging. I allowed that and it worked.

With Android, the Edison’s principle rules :))). The more you fail, the closer you get to success … yet you need to fail enough to get there

That’s certainly true! Several hours of failure yesterday, figuring it out was a nice ending though. Now for more of the same this afternoon!

One thing I can say is that both Android and IOS can be built in any complexity level. You just need to find the right updated plugins, have a properly setup machine, learn your tricks, cheats etc.

Yeah, finding all these things can be a nightmare. Yesterday I found out that the WSL Ubuntu kernel is updated via windows and that adb will only work through windows. I was expecting setting wireless debugging up to be another nightmare today but it actually just worked using adb connect ip:port

Guess I’ll find out soon what I’m in for next lol

When I started coding with Meteor 9 years ago, my “mentor” at that time advised me to buy a Mac. I still appreciate his advice every time I see someone here or in stackoverflow starting with “I’m on Windows …” or Ubuntu for that matter… :slight_smile:

Yeah I can see how that advice would be useful. I’ve always been using some combination of windows and linux, that’s just the way its been for me. Developing Meteor for 9 years, wow. I first started using it probably around that time too, it was before version 1 was released, back in the good ole days :slight_smile: