Simple todos app problems


#1

Hello,

I am using the latest version of Atom and Meteor, but when i create a map with meteor create, all works well, but i see no subdirectory imports with files like body.js.
How can i fix this problem? I want to do the SImple Todos app excercise, but i can’t go on, now.


#2

Just create the directory.


#3

I read that in the structure, it should be generated automatically. With me it doesn’t.
If i am at the prompt and i type in meteor create imports, it is not allowed.
Of course i create the folder in windows, but then i dont have the body.js file in it, which i cant create in the folder.
So i am clueless now.


#4

Why can’t you create a file in a folder?


#5

i have tried that, but i thought that it wasnt possible.
i will try it again. thanks


#6

How can i create body.js en body.html ? I see no formats to do so.


#7

Try the new --full option with meteor create

Options:
  --package  Create a new meteor package instead of an app.
  --example  Example template to use.
  --list     Show list of available examples.
  --bare     Create an empty app.
  --full     Create a scaffolded app.

#8

Thanks. Now it gets installed.


#9

This is a little too difficult for a beginner…deleted all and started again.
I still dont see how i can create a body.js and .html file in the created folder imports/ui…


#10

What editor are you using? You could actually just create the files with any notepad, save the files with to correct extention (.js or .html) and make sure you save them in the correct place.

I don’t understand what your problem is.


#11

Ok, i can of course save it as a body.js file. I work with Atom. Thanks Deelux.


#12

I can imagine that also in Atom, there is a simple way to create a new file. Most of the times it’s right clicking the folder and then selecting create new file. I don’t work with Atom but I imagine it works the same there. Good luck.