[SOLVED] Bought a macbook, can't run meteor, need help :(


#1

When I run the meteor command I get the following error:

What can I do to fix this?

Thanks!


#2

There was a similar issue earlier it was due to icloud sync automatically enabled on Sierra, one option is disable sync other is move the meteor project to folders which aren’t automatically synced


#3

I haven’t setup my icloud yet

I made a new project via meteor create and it worked.

The meteor project I’m trying to run is version 1.2 and when I run meteor it does this Downloading meteor-tool@1.1.11-faster then crashes to the error above.


#4

Did you copy your code from a windows machine?

You might need to just copy the source code and rebuild the .meteor directory by adding the right packages and installing the npm modules again.


#5

I did a git clone, the .meteor folder doesn’t have any local folder in it. It’s meteor 1.2 so it doesn’t have any npm dependencies, only bower.

Edit

Tried running another project with version 1.3 and it gave me the same error, after trying to download the meteor tools it gave me that log.


#6

have you tried running meteor reset inside the project folder? if you cloned it from git, maybe something got damaged, is incomplete or whatever…


#7

If I run meteor rester it starts downloading the meteor tools as well and crashes

Tried running meteor with sudo and it got stucked at downloading tools and didn’t do anything else, left it there the whole night. :frowning:


#8

For those having similar issues I solved it by installing nvm and using node version 0.10.40 and then running meteor inside the project and it worked.


#9

Well it appears the error is back again this time with a meteor 1.3 project that is using node version 4.5.0

I’ve tried applying the same fix as above by nvm install 4.5.0 but it didn’t work…


#10

I’m thinking because anything < 1.4 was still on node 0.10.x. Only at 1.4 did we get up to 4.5.0.


#11

I was able to get it running by doing https://install.meteor.com/?release=1.3.2.4 | sh and now everything seems to work even the 1.2 and 1.3, haven’t tested 1.4 yet but hopefully it works.