[SOLVED] Can't use meteor npm anymore after meteor update


#1

Hey,

I have a big problem with my current meteor project.
When I perform a meteor update to 1.5.1 (from 1.5), I am unable to do any “meteor npm” after that.

Exemple with meteor npm install, but it’s the same for meteor npm update, meteor npm …

meteor npm install --save ANYTHING
npm ERR! git fetch -a origin (https://github.com/meteor/readable-stream.git) fatal: Unable to find remote helper for 'https'
npm ERR! code 128
npm ERR! Command failed: git -c core.longpaths=true fetch -a origin
npm ERR! fatal: Unable to find remote helper for 'https'
npm ERR!

npm ERR! A complete log of this run can be found in:

Any idea why ? I tried reinstalling meteor, git, same thing. The only way to use packages is with ‘npm’ basic command.

EDIT : Someone ? I’m desperate … tried almost everything right now. Seems to be because of an update made after meteor 1.5 on some meteor packages.
All my packages are installed using npm directly (not meteor npm). Should I redo everything from a basic meteor create using meteor npm ?


#2

Yes. :slight_smile:

Seriously though, it’s highly recommended that you always use meteor npm as this ensures you’re using the version of npm that is bundled with your current version of Meteor. The version of npm that’s bundled with Meteor is the latest version that’s guaranteed to work with Meteor. If you’re using npm outside of Meteor, it’s possible you’re using a newer version that might have introduced differences around how the node_modules directory is organized (for example). Those differences could cause problems with Meteor. The good news is you don’t have to go back to meteor create to change this around. Just remove your APP_ROOT/node_modules directory, and run a meteor npm install.

The above being said, those changes won’t necessarily address your issue. Have you tried a meteor reset? (usual warning - this will wipe your local database; if you want to keep your database, remove everything in APP_ROOT/.meteor/local except the db directory).


#3

Jesus, I swear I tried everything to make meteor npm work but I didn’t try to reset my projet (./meteor/local and node modules) and then to install all the packages with meteor npm …

Solved thanks to you. I swear I will always use meteor npm now.


#4

Follow three steps: I have tested app after this workaround:

  1. Issue below command at command prompt

    meteor create dAppDemo
    (Ignore warnings with npm https)

  2. cd dAppDemo

  3. dAppDemo > meteor reset

  4. dAppDemo > meteor npm install
    (this will load all npm modules for you)