[SOLVED] Changelog for alanning:roles 4.0.0-alpha.3

I see this : alanning:roles 4.0.0-alpha.2 (4.0.0-alpha.3 is available)

I would like to know what has changed but I cannot find the changelog of this alpha version. Can you give me the link to it ?


it seems also that version of blaze is not properly set in alanning roles

=> Errors prevented startup:                  
   While selecting package versions:
   error: Conflict: Constraint blaze@2.9.0 is not satisfied by blaze 3.0.0-rc300.2.
   Constraints on package "blaze":
   * blaze@3.0.0-rc300.2 <- top level
   * blaze@3.0.0-rc300.2 <- blaze-html-templates 3.0.0-rc300.2
   * blaze@3.0.0-rc300.2 <- spacebars 2.0.0-rc300.2 <- rationalk:bpm 0.0.0
   * blaze@3.0.0-rc300.2 <- templating-runtime 2.0.0-rc300.2 <- templating 1.4.4-rc300.2 <- aldeed:tabular 2.1.2 <- rationalk:core 0.0.0
   * blaze@3.0.0-rc300.2 <- templating-runtime 2.0.0-rc300.2 <- templating 1.4.4-rc300.2 <- blaze-html-templates 3.0.0-rc300.2
   * blaze@3.0.0-alpha300.17 <- accounts-base 3.0.0-rc300.2
   * blaze@2.7.1 || 2.8.0 || 2.9.0 || 3.0.0-alpha300.0 <- ostrio:flow-router-extra 3.11.0-rc300.1
   * blaze@2.9.0 <- alanning:roles 4.0.0-alpha.3
=> Your application has errors. Waiting for file change.

Are there no github links from atmosphere nor packosphere available? At the very least, the commits to those repositories can help

Yep, the problem is that Blaze is pinned in this package to version 2.9. To fix this, the version needs to be updated to something like this: blaze@2.9.0 || 3.0.0-rc300.2.

A PR is open for this package to be updated to version 4 and compatible with Meteor 3.

I’ve tried to push these changes, but I don’t have permission to publish this package… \

@storyteller can you help here? I see that you already published this package once.

1 Like

Yes, will release a new version shortly.

Update: Published alanning:roles@4.0.0-alpha.4 with the updated Blaze dependency.

You can find the full list of the changes in the changelog of the PR and on the PR itself that @denyhs pointed out.


I was able to install alanning:roles@4.0.0-alpha.4. It is working perfectly.

1 Like