SOLVED: Crashing after upgrade to 1.4


#1

I did meteor update and then meteor reset to upgrade Mongo database to the latest per instructions. Now when I do meteor run I get this error:

TypeError: Error.captureStackTrace is not a function
    at Error.MongoError (/Users/alex/.meteor/packages/npm-mongo/.1.5.45.1xmxoov++os+web.browser+web.cordova/npm/node_modules/mongodb-core/lib/error.js:13:9)
    at Function.MongoError.create (/Users/alex/.meteor/packages/npm-mongo/.1.5.45.1xmxoov++os+web.browser+web.cordova/npm/node_modules/mongodb-core/lib/error.js:29:11)
    at Socket.<anonymous> (/Users/alex/.meteor/packages/npm-mongo/.1.5.45.1xmxoov++os+web.browser+web.cordova/npm/node_modules/mongodb-core/lib/connection/connection.js:175:22)
    at Socket.g (events.js:260:16)
    at emitOne (events.js:77:13)
    at Socket.emit (events.js:169:7)
    at TCP._onclose (net.js:486:12)

There is something being cached for the existing project. I created a new project that compiled and ran just fine.


#2

Try deleting the local directory that is inside .meteor directory and run meteor.


#3

I deleted everything and still have the same issue. Completely removed .meteor/local, removed /Users/alex/.meteor folder, removed node_modules and did npm install (just in case). Then ran meteor update – it reinstalled everything. Then did meteor run and the same error came back.


#4

Hey, Can you please open an issue on github with a simple reproduction. Thanks.


#5

Solved:

So I reset the database, wiping everything out. But I had this line in Meteor.startup:

Airports._ensureIndex({"location": "2dsphere"});

After I commented it out the application ran without crashing. Confirmed by uncommenting and receiving the same error.