[SOLVED] Deploying 1.6 with mup fails


#1
/opt/safeantiques/app/programs/server/boot.js:50
    const { pause } = require("./debug.js");
          ^

SyntaxError: Unexpected token {

#2

Upgrading to Node 8.8.1 fixed it


#3

Hi Mickael, I have the same problem, could you explain how to go about upgrading to Node 8.8.1?


#4

Same problem, even when I install Node 8.8.1…


#5

I upgraded to Node 8.8.1 on the development pc, which didn’t help, and the error is coming from the server anyway. I see mup used to have a nodeVersion option, but that no longer seems to be supported. I thought that mup always installs the right Node version for the version of Meteor, and can’t see how to change that. Any further guidance form Mickael would be much appreciated.


#6

See here: https://hub.docker.com/r/abernix/meteord/ for updating the docker image to one that uses the correct version of node for meteor 1.6.

e.g.

image: 'abernix/meteord:node-8.4.0-base',

#7

Thanks that has resolved the issue.


#8

Thank you, this fixed it for me.


#9

Thank you so much. Worked like charm!


#10

MickaelFM uses this classic version of mup https://github.com/M4v3R/meteor-up
that’s why he did not change the version of docker but the node version in mup.json :wink:


#11

Just as a sidenote: About the abernix/meteord/base docker image:
I already pm’ed @abernix about updating the base to node 8.8.1. Hopefully he will reply soon and provide an updated image. :slight_smile:


#12

Just to help people to find this error, the MUP report this error as “502 Bad Gateway” and is related in mup project with SSL.

I expend hours trying to find a solution in that way, until someone point to me to the logs and this thread.


#13

This might be an incredibly stupid question, but will this image change affect the existing mongodb data in any way? I’m afraid of losing the current live data.


#14

Nope, the mongo uses a different image, and almost certainly uses a docker volume (mounts to a folder on your server)


#15

Thanks, much appreciated. I will do a manual backup and give this a try, hopefully the fix will work.


#16

I moved to abernix/meteord:node-8.9.0-base image but I’m still getting the same error. Any thoughts?


#17

Me too… Node version 8.4.0 and using abernix/meteord:node-8.4.0-base. I’m getting sick of this


#18

I just ran into this exact error when using Node 4 to run an app which was meteor build (built) with Meteor 1.6.

Are those experiencing this absolutely positive that they’re using the correct Docker image?


#19

I sometimes ran into weird mup errors which could be fixed by just running docker stop <your-container> before deploying a new version. don’t ask me why this helped but maybe try that first!


#20

There is a 10% chance that I had improperly tagged an abernix/meteord base Node.js 8 image as a Node.js 4 for a period of time. I can’t validate this, but it’s possible, and I would have accidentally fixed it already.