[SOLVED] ECONNRESET Error On Startup (v2.7.1)

Hello,

I recently updated our project to 2.7.1, and now I am unable to start the app locally.

Here is the error I get when trying to start:

=> Started proxy.                             
events.js:377                                 
      throw er; // Unhandled 'error' event
      ^

Error: read ECONNRESET
    at TLSWrap.onStreamRead (internal/stream_base_commons.js:209:20)
Emitted 'error' event on ClientRequest instance at:
    at TLSSocket.socketErrorListener (_http_client.js:475:9)
    at TLSSocket.emit (events.js:400:28)
    at emitErrorNT (internal/streams/destroy.js:106:8)
    at emitErrorCloseNT (internal/streams/destroy.js:74:3)
    at processTicksAndRejections (internal/process/task_queues.js:82:21) {
  errno: -54,
  code: 'ECONNRESET',
  syscall: 'read'
}

I upgraded from 2.2.4, so it’s a pretty major bump. I went one major version at a time. I first saw this error on v2.5.6 but it seemed to go away after upgrading a few packages and doing a meteor reset. Had a full day of it working, and then this morning I am once again unable to start meteor up.

I’ve tried meteor reset, and a full reinstallation of meteor (just running curl https://install.meteor.com/ | sh so maybe there is something I am missing there.

Any help is appreciated!

Thanks,
Sean

Turns out there was an issue importing a font.

@import url(https://fonts.googleapis.com/css?family=Source+Sans+Pro:300,400,600,700,300italic,400italic,600italic);

I moved it into the head and it works fine now. Not really sure what the deal is there.

1 Like