[SOLVED] ENOENT error, windows 10, missing 'allow-deny.js'

Hi all,

I updated meteor to 1.7, then I started a brand new project using

meteor create --bare [folder]

and I can’t get it to start. I got the following when I tried .

C:\Users\ [user]\AppData\Local.meteor\packages\meteor-tool\1.7.0_3\mt-os.windows.x86_64\dev_bundle\lib\node_modules\meteor-promise\promise_server.js:218
throw error;

Error: ENOENT: no such file or directory, open ‘C:\Users\ [user]\AppData\Local.meteor\packages\allow-deny\1.1.0\os\allow-deny.js’

at C:\tools\runners\run-app.js:408:12

I checked and yeah, there is no file in that folder. The folder is there, but it is empty. Perhaps useful: there are 2 other folders under 1.1.0: web.browser and web.cordova. The former is empty but the latter is not. Looks like an oversight that should be an easy fix.

But, for now, I am stopped. Meteor can’t run, I can’t do. :slight_smile: EDIT: Running windows 10, and running cmd as administrator.

Sounds like a failed package download. Easiest fix is to delete the C:\Users\[user]\AppData\Local.meteor\packages\allow-deny folder so Meteor will try to download it again.

Any time I get an ENOENT or EPERM error on Windows I just delete that directory or a relevant parent dir till it gets fixed. It’s dumb but works 75% of the time

Just saw your edit:


It’s needed for the choco install, but other than that never run meteor as an administrator or it will completely hose the permissions on all folders Meteor uses; usually requiring a full re-install.

Instead of the previous advice, you should start with a re-install:

// In an administrator prompt
choco uninstall meteor -y
choco install meteor -y

Then close the administrator prompt and open a regular one before continuing

1 Like

I was in the midst of doing a full reinstall when I read this…so…yeah, you can be sure I am gonna follow your advice. It would be nice if this little nugget was included someplace in the installation directions. I’m working on it, and will reply if this solves it.

1 Like

Yeah it really should be, it’s so easy to just enter all the commands in the same prompt

  1. I reinstalled meteor using the above steps using choco as admin.
  2. I exited cmd and then opened it not as administrator.
  3. I created a --bare project
  4. It gave me no errors in creation or in running.

Also, the file that the previous error was missing…is now there. So marked this as solved…provided somebody commits to adding the no admin part in the windows installation instructions. As much as I’d like this to be an all-Linux world, we don’t live there…yet.

Thanks all. (I will keep the delete and run update again in mind as well)

1 Like

Erm, it‘s the exact same way on Linux. Install stuff as admin, DON‘T run it as admin.

Actually, in Linux you install as yourself. The installer prompts for sudo access only when it needs to save the binary into /usr/local/bin/.

Still doesn‘t change the fact that this issue also exists on Linux. As such it‘s disingenuous to blame Windows for this.

@rhywden is absolutely correct.
I do find it easier to make permissions mistakes in Windows because of the specific workflow needed to install Meteor.
ie. Using an always elevated prompt, vs using sudo for single commands that require elevation