[SOLVED] Error in installing fibers

Hello everybody,
I run Ubuntu 18.04.6 LTS and it was always working well and then today when I try to update, I got this →

I tried a lot of different things but nothing was a success.

Do you have any idea ?
Thanks a lot


Can you give us more context?
Which Meteor version? NPM Version? Node version?
Update from which version and to which version?

From the images, looks like node 12.22.1; no info there about npm version

@dokithonon did you try the instructions in the console and run:

sudo apt-get install g++ build-essentials and did that have any impact?

And can you provide the contents of the debug log file listed above?

Error mentioned in the first image says “Error: self signed certificate in certificate chain” @hschmaiske does this look like a cause or symptom?

Thanks for your answers.
We have npm version 6.14.12 node version v12.22.1 (node version used by npm)
We are on the last meteor version.

Yes we tried sudo apt-get install g++ build-essentials without any success.

Earlier this year or last year there was a change in a global/root ssl certificate on the web. Can it be linked to this ?

I have extracted this morning the log file from npm as you asked

4687 info build /data/apps/bundle-npm-install-fail-20220825/programs/server/npm/node_modules/fibers
4688 info lifecycle fibers@5.0.2~preinstall: fibers@5.0.2
4689 info linkStuff fibers@5.0.2
4690 silly linkStuff fibers@5.0.2 has /data/apps/bundle-npm-install-fail-20220825/programs/server/npm/node_modules as its parent node_modules
4691 info lifecycle fibers@5.0.2~install: fibers@5.0.2
4692 verbose lifecycle fibers@5.0.2~install: unsafe-perm in lifecycle true
4693 verbose lifecycle fibers@5.0.2~install: PATH: /usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/data/apps/bundle-npm-install-fail-20220825/programs/server/npm/node_modules/fibers/node_modules/.bin:/data/apps/bundle-npm-install-fail-20220825/programs/server/npm/node_modules/.bin:/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin:/usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/data/apps/bundle-npm-install-fail-20220825/programs/server/node_modules/.bin:/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
4694 verbose lifecycle fibers@5.0.2~install: CWD: /data/apps/bundle-npm-install-fail-20220825/programs/server/npm/node_modules/fibers
4695 silly lifecycle fibers@5.0.2~install: Args: [ '-c', 'node build.js || nodejs build.js' ]
4696 silly lifecycle fibers@5.0.2~install: Returned: code: 1  signal: null
4697 info lifecycle fibers@5.0.2~install: Failed to exec install script
4698 verbose stack Error: fibers@5.0.2 install: `node build.js || nodejs build.js`
4698 verbose stack Exit status 1
4698 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
4698 verbose stack     at EventEmitter.emit (events.js:314:20)
4698 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
4698 verbose stack     at ChildProcess.emit (events.js:314:20)
4698 verbose stack     at maybeClose (internal/child_process.js:1022:16)
4698 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)
4699 verbose pkgid fibers@5.0.2
4700 verbose cwd /data/apps/bundle-npm-install-fail-20220825/programs/server/npm
4701 verbose Linux 4.15.0-188-generic
4702 verbose argv "/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin/node" "/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin/npm" "rebuild" "--update-binary"
4703 verbose node v12.22.1
4704 verbose npm  v6.14.12
4705 error code ELIFECYCLE
4706 error errno 1
4707 error fibers@5.0.2 install: `node build.js || nodejs build.js`
4707 error Exit status 1
4708 error Failed at the fibers@5.0.2 install script.
4708 error This is probably not a problem with npm. There is likely additional logging output above.
4709 verbose exit [ 1, true ]

And this one :

517 silly build meteor-dev-bundle@
518 info linkStuff meteor-dev-bundle@
519 silly linkStuff meteor-dev-bundle@ has /data/apps/bundle-npm-install-fail-20220825/programs as its parent node_modules
520 silly install meteor-dev-bundle@
521 info lifecycle meteor-dev-bundle@~install: meteor-dev-bundle@
522 verbose lifecycle meteor-dev-bundle@~install: unsafe-perm in lifecycle true
523 verbose lifecycle meteor-dev-bundle@~install: PATH: /usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/data/apps/bundle-npm-install-fail-20220825/programs/server/node_modules/.bin:/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
524 verbose lifecycle meteor-dev-bundle@~install: CWD: /data/apps/bundle-npm-install-fail-20220825/programs/server
525 silly lifecycle meteor-dev-bundle@~install: Args: [ '-c', 'node npm-rebuild.js' ]
526 timing audit submit Completed in 229ms
527 http fetch POST 200 https://registry.npmjs.org/-/npm/v1/security/audits/quick 229ms
528 timing audit body Completed in 0ms
529 silly lifecycle meteor-dev-bundle@~install: Returned: code: 1  signal: null
530 info lifecycle meteor-dev-bundle@~install: Failed to exec install script
531 verbose stack Error: meteor-dev-bundle@ install: `node npm-rebuild.js`
531 verbose stack Exit status 1
531 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
531 verbose stack     at EventEmitter.emit (events.js:314:20)
531 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/nodejs/node-v12.22.1-linux-x64/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
531 verbose stack     at ChildProcess.emit (events.js:314:20)
531 verbose stack     at maybeClose (internal/child_process.js:1022:16)
531 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)
532 verbose pkgid meteor-dev-bundle@
533 verbose cwd /data/apps/bundle-npm-install-fail-20220825/programs/server
534 verbose Linux 4.15.0-188-generic
535 verbose argv "/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin/node" "/usr/local/lib/nodejs/node-v12.22.1-linux-x64/bin/npm" "install"
536 verbose node v12.22.1
537 verbose npm  v6.14.12
538 error code ELIFECYCLE
539 error errno 1
540 error meteor-dev-bundle@ install: `node npm-rebuild.js`
540 error Exit status 1
541 error Failed at the meteor-dev-bundle@ install script.
541 error This is probably not a problem with npm. There is likely additional logging output above.
542 verbose exit [ 1, true ]

It may be related to the nodejs version, try updating to node 14
also, are you trying to connect to a local MongoDB or external?
Try adding this to your MONGO URL &tlsAllowInvalidCertificates=true

The error occurs during npm install so I don’t think changing the mongo url will make anything. We are connecting to a local mongo.

I will try to upgrade node and npm.

The solution was to update node to v14.
Thanks for your help

1 Like