[SOLVED] Facebook login (accounts-facebook) stopped working

We’re seeing a really weird behavior with facebook login not working anymore - yes, it used to work fine, but we have no idea when it stopped working exactly. It still works on our old, production build.

The only hint that there is, is the log output from xcode when I run the app in the iOS simulator:

2020-02-08 07:48:33.089602+0000 [3068:59613] WF: === Starting WebFilter logging for process xxxxx
2020-02-08 07:48:33.089739+0000 [3068:59613] WF: _userSettingsForUser : (null)
2020-02-08 07:48:33.089837+0000 [3068:59613] WF: _WebFilterIsActive returning: NO

I have Googled extensively and all WebFilter mentions I could find were related to access rules.

However, in all logs I’ve seen posted, the line that refers to _userSettingsForUser comes up with a value, when in our specific case it comes up with null. Needless to say that I have already added all domains that facebook accesses to the the rules with no difference.

Any ideas?

Would you please be interested to give this package a try? I didn’t update this package for some time but unless the FB SDK version was deprecated, this should still work and I will update to the latest version soon.

@paulishca this doesn’t seem to work out of the box with accounts-facebook, I’d have to replace the accounts-base template to make it work

Because you mentioned IOS Simulator I assumed you are interested in Facebook login with Cordova. If Yes, I do not thing that accounts-facebook can help you with that as you need to use a Cordova package to handle the security and callbacks.

As stated we were using the default accounts-base+accounts-facebook combo which launches an InAppBrowser to get the log in done.

Thank you for trying to help anyway. I managed to trace the problem to updating the cordova-plugin-inappbrowser and cordova-plugin-whitelist to latest versions.

I’m stuck with the same problem… Nevertheless, it works on iOS12 devices, the problem only appears with iOS 13… Did you find versions of cordova-plugin-inappbrowser and cordova-plugin-whitelist which make it work on iOS13 devices ?

(I have tried the other ways, like FB JS SDK and cordova-facebook4, but none of them seem to work with iOS 13 / cordova ios < 5.1, which is all we can get in Meteor to this day as far as I understand…)

Hey Lek - yes it seems to work on an iOS simulated phone with 13.3

cordova-plugin-inappbrowser@3.2.0
cordova-plugin-whitelist@1.3.4

This is with meteor 1.8.1

Hi Georgiosd, thanks a lot !

Just tried it and it works perfectly (Meteor 1.9), thank you so much, this really helped me !!!

Feels like meeting a real-life avenger :slight_smile: :slight_smile: :slight_smile:

Cheers !

1 Like

I’m so glad it helped you out Lek :slight_smile:

For what it’s worth, I spent hours and hours trying to fix this, and I only thought of looking at the cordova plugins by chance when someone mentioned the version of cordova-ios in a slightly unrelated issue.

1 Like