[Solved] Galaxy A-P Deployment giving ERR! Invalid version: "https://registry.npmjs.org/Base64/-/Base64-0.2.1.tgz"

Since yesterday, attempts to deploy my app to Galaxy Asia-Pac are failing with this error message:
ERR! Invalid version: “https://registry.npmjs.org/Base64/-/Base64-0.2.1.tgz

The change I am deploying is a minor code change only (literally changing content of a text string) - so no changes to package or npm module versions or anything like that.

The build status ends as “successful”, however Galaxy then “fails to deploy” and rolls back to the previous successful build.

Meteor version is and this is build # 98 for this app (deployment worked fine the first 97 times!)

Tried re-deploying previously successful build and that also failed.

Even tried with Meteor 1.6 in case it was in any way related to the Meteor 1.6 update rollout - and still no joy.

Open to any ideas / suggestions. Hoping someone else has hit and solved it. I will report back if I manage to do the same or if Galaxy support shed any light on it!

1 Like

Solved this by deleting package-lock.json file and running meteor npm update to regenerate it.

With the new package.json and package-lock.json files, deployment succeeded.

Hope this helps the next person!