SOLVED: Getting issue in build iOS project after upgrade to 1.3


#1

Hi,
not sure what’s wrong here.
When building and installing my app on iPad, I get stuck on the splashscreen.
This is what I get with the debugger:

2016-04-27 17:56:55.984 Business Test[727:260653] Apache Cordova native platform version 4.1.0 is starting.
2016-04-27 17:56:55.985 Business Test[727:260653] Multi-tasking -> Device: YES, App: YES
2016-04-27 17:56:55.992 Business Test[727:260653] 

Started backup to iCloud! Please be careful.
Your application might be rejected by Apple if you store too much data.
For more information please read "iOS Data Storage Guidelines" at:
https://developer.apple.com/icloud/documentation/data-storage/
To disable web storage backup to iCloud, set the BackupWebStorage preference to "local" in the Cordova config.xml file

2016-04-27 17:56:56.066 Business Test[727:260653] Using WKWebView
2016-04-27 17:56:56.067 Business Test[727:260653] [CDVTimer][handleopenurl] 0.110984ms
2016-04-27 17:56:56.070 Business Test[727:260653] [CDVTimer][intentandnavigationfilter] 2.559960ms
2016-04-27 17:56:56.070 Business Test[727:260653] [CDVTimer][gesturehandler] 0.091970ms
2016-04-27 17:56:56.140 Business Test[727:260653] Serving asset bundle version: a1ce998c8b1a58a76c8590f52548b40bcb6af7e5
[INFO] GCDWebServer started on port 12864 and reachable at http://localhost:12864/
2016-04-27 17:56:56.142 Business Test[727:260653] [CDVTimer][webapplocalserver] 72.483957ms
2016-04-27 17:56:56.149 Business Test[727:260653] [CDVTimer][statusbar] 6.622970ms
2016-04-27 17:56:56.159 Business Test[727:260653] [CDVTimer][splashscreen] 10.060012ms
2016-04-27 17:56:56.160 Business Test[727:260653] [CDVTimer][TotalPluginStartup] 92.954993ms
2016-04-27 17:57:16.899 Business Test[727:260880] App startup timed out, reverting to last known good version

Any ideas? I’m connecting to a remote server hosted on Modulus with this build command:
meteor build --server=https://<my-server>.onmodulus.net --verbose


#2

When inspecting the build in the browser console, I’m getting that it cannot find Meteor.settings. Is Meteor.settings somehow being read from the new build in local web server?


#3

This solved itself by following advice from this post: Mobile guide article

Basically, I needed to link in my settings.json using --mobile-settings when building.