[solved] How to provide NODE_OPTIONS in 2.3.5?

Tried to add node options as stated in the current docs. But SERVER_NODE_OPTIONS seems to be no longer supported for the current meteor run as I get this output for running meteor:

‘SERVER_NODE_OPTIONS=–trace-deprecation’ is not a Meteor command. See ‘meteor --help’.

Any ideas on how to get a traceback as I am trying to see what causes this error?

W20210827-13:54:35.189(2)? (STDERR) (node:23804) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.

W20210827-13:54:35.298(2)? (STDERR) (Use node --trace-deprecation ... to show where the warning was created)

Are you using it correctly?

In Linux:

SERVER_NODE_OPTIONS=--trace-deprecation meteor run

In Windows (PS):

$env:SERVER_NODE_OPTIONS = '--trace-deprecation'
meteor run
1 Like

Works like a charm, I wasn’t sure whether providing that would be picked up by meteor. Thanks.

1 Like