[SOLVED] I resized my Digital Ocean droplet but my meteor app refuses to start


#1

I resized my Digital ocean droplet (Permanently) This required I powered off my droplet and then powered on again. When I visit the webpage I get a typical NGINX page saying that I have succesfully installed NGINX, the web app can no longer be seen

I did a mup logs -f to see what is going on and I am continually getting this error.

I am not sure what is wrong and it lookslike something is off with my cron jobs but I am not sure what. Any ideas:

error: Forever detected script exited with code: 8 [xxx.xxx.xxx.xx] error: Script restart attempt #75[xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] {"line":"63","file":"synced-cron-server.js","message":"SyncedCron: Scheduled \"Email Weekly Todos for Mentors\" next run @Mon Nov 30 2015 07:00:00 GMT-0500 (EST)","time":{"$date":1448741207434},"level":"info"}[xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] {"line":"63","file":"synced-cron-server.js","message":"SyncedCron: Scheduled \"Weekly Push Notifications to students\" next run @Sun Nov 29 2015 10:00:00 GMT-0500 (EST)","time":{"$date":1448741207437},"level":"info"}[xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] events.js:72[xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] throw er; // Unhandled 'error' event [xxx.xxx.xxx.xx] [xxx.xxx.xxx.xx] ^ Error: listen EADDRINUSE at errnoException (net.js:905:11) at Server._listen2 (net.js:1043:14) at listen (net.js:1065:10) at net.js:1147:9 at dns.js:72:18 at process._tickCallback (node.js:442:13) error: Forever detected script exited with code: 8[xxx.xxx.xxx.xx]

Any ideas would help a lot


#2

EADDRINUSE should pointing to port already in use. Something is already running on that port.
@adim86: I updated it to english :smiley:


#3

Any ideas, im not sure what the above means


#4

Any ideas on how to kill it or see whats running? whats my next step? Thanks


#5

Use the Google my friend.

@adim86 I did have something on this however… Here’s some notes I took when I ran into the same issue once upon a time:

to dump ports used by procs use (as root) netstat -tupln
if a specific port is desired netstat -tupln | grep :PORT_NUMBER

replace PORT_NUMBER with the port you want to check (where you’re trying to run your proc)

example

[root@digitalsea ~] netstat -tulpn | grep :3306 tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 1092/mysqld

and now you know mysqld is running on port 3306.
it has a pid of 1092. you can terminate the process with kill -9 1092 (from root of course)

sauce (which told me the answer)


#6

Thank you this was very helpful

I fixed it by changing my apps configuration file in the “sites-enabled” to port “3000”, it was on PORT 80 and conflicting with NGINX

Thanks for all your help