[solved] iOS application can't normally work on 3G

Hi guys,

I have a mobile iOS app in staging that connects to the staging/production server and works completely normal when operating on Wi-Fi.

When changing that to 3G things doesn’t work anymore.

Using meteor add appcache helped to make the first screen of the app to show, but accounts is unable to display the social login buttons probably because navigator.onLoad is false.

Meteor.status() on 3G shows:

{status: "waiting", connected: false, retryCount: 6, retryTime: 1458419592304.1804}

on Wi-Fi shows:

{status: "connected", connected: true, retryCount: 0}

What should I do to make it to connect over 3G?

It seems the app is not able to connect to the server over 3G.

Any network errors in the console of the Safari remote debugger? Or in the network panel?

@martijnwalraven indeed, I’ve forgot to mention that in the console it periodically shows:

Failed to load resource: The Internet connection appears to be offline.


But, again, that’s only on 3G and not Wi-Fi


A friend in Amsterdam used it over 4G and the app went just fine so I’m starting to suspect of my carrier.

Rings any bell? Anyone has any idea of what to do?

cc/ @martijnwalraven

It seems some mobile operators use proxy servers that may have issues with WebSocket traffic. The only real solution in these cases is to force the use of SSL. Do you have the ability to try that out?

That’s a great pointer @martijnwalraven!

I’ll setup SSL and try on that.

I will update here the outcome of this attempt

I’ve just setup all on SSL and the issue remains exactly the same.

Unfortunately I couldn’t make it work on 3G.

Still seeing in console:

Failed to load resource: The Internet connection appears to be offline.

I’m running out of ideas on how to fix this.

Any further clues?

cc/ @martijnwalraven

After making a double check of the basics, I’ve found that the app was off for cellular data.

Turning it on from Settings > Cellular > theAppName made it all work just fine.

I wonder why was off in the first place or how to turn that on programatically.

1 Like

Ah, glad to hear you fixed it! I don’t think there is a way to turn that on programmatically.

1 Like