SOLVED: Isopacket load issue `logging`


#1

After upgrading to Meteor 1.5 from 1.4.1 I seem to be getting the following error:

Errors prevented isopacket load:

While loading isopacket `logging`:

/home/craignewton/.meteor/packages/meteor-tool/.1.5.0.17o7d3h++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/isopackets/logging/npm/node_modules/meteor/modules/node_modules/reify/lib/runtime/utils.js:12:38:
Symbol.for is not a function
at Object.<anonymous>
(/home/craignewton/.meteor/packages/meteor-tool/.1.5.0.17o7d3h++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/isopackets/logging/npm/node_modules/meteor/modules/node_modules/reify/lib/runtime/utils.js:12:38)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)
at Module.Mp.load (/tools/tool-env/install-runtime.js:30:27)
at Function.Module._load (module.js:300:12)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object.<anonymous>
(/home/craignewton/.meteor/packages/meteor-tool/.1.5.0.17o7d3h++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/isopackets/logging/npm/node_modules/meteor/modules/node_modules/reify/lib/runtime/index.js:8:13)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)
at Module.Mp.load (/tools/tool-env/install-runtime.js:30:27)
at Function.Module._load (module.js:300:12)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at npmRequire (/tools/isobuild/bundler.js:1960:14)
at Module.useNode (packages/modules-runtime.js:687:18)
at fileEvaluate (packages/modules-runtime.js:332:20)
at require (packages/modules-runtime.js:228:16)
at meteorInstall.node_modules.meteor.modules.reify.js
(packages/modules.js:125:1)
at fileEvaluate (packages/modules-runtime.js:333:9)
at require (packages/modules-runtime.js:228:16)
at meteorInstall.node_modules.meteor.modules.server.js
(packages/modules.js:23:1)
at fileEvaluate (packages/modules-runtime.js:333:9)
at require (packages/modules-runtime.js:228:16)
at packages/modules.js:270:15
at packages/modules.js:282:3

Anyone had a similar issue with regards to this? What would the solution be.

Thanks in advance.


#2

I manged to resolve the issue, seems like there was a package that was clashing with the native ES6 implementation in Meteor.

Solved by running: meteor remove cg5:collection-view

Which also removed the following:

cg5:collection-view  removed from your project
mrt:exports          removed from your project
tomi:es6             removed from your project

Project now starts up fine.