[SOLVED] Issues trying to run Meteor App on Ubuntu 14.04


Not sure what has happened from yesterday to today with trying to run my Meteor app on Ubuntu 14.04 but for some unknown reason to me, when I kick off a “meteor” call, I now get the following errors:

Am using Meteor version: v1.2.1 and Node version: v4.4.0

=> Started proxy.
=> Started MongoDB.
W20160318-02:26:43.390(11)? (STDERR)
W20160318-02:26:43.393(11)? (STDERR) Error: Cannot find module 'fibers’
W20160318-02:26:43.394(11)? (STDERR) at Function.Module._resolveFilename (module.js:338:15)
W20160318-02:26:43.394(11)? (STDERR) at Function.Module._load (module.js:280:25)
W20160318-02:26:43.394(11)? (STDERR) at Module.require (module.js:364:17)
W20160318-02:26:43.395(11)? (STDERR) at require (module.js:380:17)
W20160318-02:26:43.395(11)? (STDERR) at Object. (/home/horizon/Meteor_Work/Coursera/dev/textcircle/.meteor/local/build/programs/server/boot.js:1:75)
W20160318-02:26:43.395(11)? (STDERR) at Module._compile (module.js:456:26)
W20160318-02:26:43.397(11)? (STDERR) at Object.Module._extensions…js (module.js:474:10)
W20160318-02:26:43.397(11)? (STDERR) at Module.load (module.js:356:32)
W20160318-02:26:43.398(11)? (STDERR) at Function.Module._load (module.js:312:12)
W20160318-02:26:43.398(11)? (STDERR) at Module.require (module.js:364:17)
W20160318-02:26:43.392(11)? (STDERR) module.js:340
W20160318-02:26:43.393(11)? (STDERR) throw err;
W20160318-02:26:43.393(11)? (STDERR) ^
=> Exited with code: 8
W20160318-02:27:02.137(11)? (STDERR)
W20160318-02:27:02.140(11)? (STDERR) module.js:340
W20160318-02:27:02.143(11)? (STDERR) throw err;
W20160318-02:27:02.143(11)? (STDERR) ^
W20160318-02:27:02.144(11)? (STDERR) Error: Cannot find module 'fibers’
W20160318-02:27:02.145(11)? (STDERR) at Function.Module._resolveFilename (module.js:338:15)
W20160318-02:27:02.145(11)? (STDERR) at Function.Module._load (module.js:280:25)
W20160318-02:27:02.146(11)? (STDERR) at Module.require (module.js:364:17)
W20160318-02:27:02.146(11)? (STDERR) at require (module.js:380:17)
W20160318-02:27:02.146(11)? (STDERR) at Object. (/home/horizon/Meteor_Work/Coursera/dev/textcircle/.meteor/local/build/programs/server/boot.js:1:75)
W20160318-02:27:02.147(11)? (STDERR) at Module._compile (module.js:456:26)
W20160318-02:27:02.147(11)? (STDERR) at Object.Module._extensions…js (module.js:474:10)
W20160318-02:27:02.148(11)? (STDERR) at Module.load (module.js:356:32)
W20160318-02:27:02.148(11)? (STDERR) at Function.Module._load (module.js:312:12)
W20160318-02:27:02.149(11)? (STDERR) at Module.require (module.js:364:17)
=> Exited with code: 8
W20160318-02:27:21.000(11)? (STDERR)
W20160318-02:27:21.001(11)? (STDERR) module.js:340
W20160318-02:27:21.001(11)? (STDERR) throw err;
W20160318-02:27:21.001(11)? (STDERR) ^
W20160318-02:27:21.006(11)? (STDERR) Error: Cannot find module 'fibers’
W20160318-02:27:21.006(11)? (STDERR) at Function.Module._resolveFilename (module.js:338:15)
W20160318-02:27:21.007(11)? (STDERR) at Function.Module._load (module.js:280:25)
W20160318-02:27:21.007(11)? (STDERR) at Module.require (module.js:364:17)
W20160318-02:27:21.008(11)? (STDERR) at require (module.js:380:17)
W20160318-02:27:21.008(11)? (STDERR) at Object. (/home/horizon/Meteor_Work/Coursera/dev/textcircle/.meteor/local/build/programs/server/boot.js:1:75)
W20160318-02:27:21.008(11)? (STDERR) at Module._compile (module.js:456:26)
W20160318-02:27:21.009(11)? (STDERR) at Object.Module._extensions…js (module.js:474:10)
W20160318-02:27:21.009(11)? (STDERR) at Module.load (module.js:356:32)
W20160318-02:27:21.010(11)? (STDERR) at Function.Module._load (module.js:312:12)
W20160318-02:27:21.010(11)? (STDERR) at Module.require (module.js:364:17)
=> Exited with code: 8
=> Your application is crashing. Waiting for file change.

Can someone pls assist as I am at a loss to what’s happened all of a sudden.


Have you tried a meteor reset? (usual disclaimer - will wipe your apps local DB)

First, reinstall Meteor.

If this doesn’t solve your problem:
Then meteor list and meteor update. If there are packages listed as has new version when you meteor list but cannot be upgraded by meteor update, try meteor installing them.

If that doesn’t solve your problem either:
Write down whatever additional Meteor packages you installed for that app.
Create a new Meteor app.
Copy your files (including any VCS files) over to the new Meteor app.
Re-install the additional Meteor packages in the new app.
Everything should be working fine in the new app.


Firstly, tried the “meteor reset” approach and unfortunately did not solve my problem.

I then tried the re-installation of Meteor and this solved my issue. Just in case others come across this issue, I simply performed the following steps:

  1. Delete the file /usr/local/bin/meteor
  2. Delete the folder ~/.meteor
  3. sudo curl https://install.meteor.com | /bin/sh

My concern still is, why did I get this problem in the first place as I don’t believe I did anything out of the ordinary?

Can anyone pls assist as I’m concerned it may happen again.


Are you by any chance using a VCS like git? This happened to me once when I was jumping between branches and doing some merges. I suspect since the .meteor folder becomes part of the repository, package definitions may get lost in the process.

Are you running on a VM with limited disk space? I’ve seen something similar when contents of the ~/.meteor folder filled the virtual disk.

Thanks for the replies guys but the answer to both am I using VCS and running on a VM? = no.

Could be an issue with the Node version? I thought Meteor only supported lower versions of Node …

Interesting. Can you pls let me know what version of Node, Meteor 1.2.1 supports?