[SOLVED] Localhost:3000 takes longtime to get data from server on Linux Mint


#1

NOTE: Everything works well today, I don’t know the problem but Everything works fine now on both local and online server.


Hi,
I started learning Meteor yesterday on Window 7. Everything worked well through multiple lessons.

When I started today on Linux Mint.

meteor create simple-todos
cd simple-todos
meteor
[[[[[ ~/simple-todos ]]]]]

=> Started proxy.                             
=> Started MongoDB.                           
=> Started your app.                          

=> App running at: http://localhost:3000/

Then go to the browser http://localhost:3000, it takes long time loading without response.

When I tried this in the terminal

curl http://localhost:3000      # It displays the returned HTML in the terminal.

I’ve noticed that the returned output is without body content

<!DOCTYPE html>
<html>
<head>
  <link rel="stylesheet" type="text/css" class="__meteor-css__" href="/20ae2c8d51b2507244e598844414ecdec2615ce3.css">


<script type="text/javascript">__meteor_runtime_config__ = JSON.parse(decodeURIComponent("%7B%22meteorRelease%22%3A%22METEOR%401.1.0.2%22%2C%22ROOT_URL%22%3A%22http%3A%2F%2Flocalhost%3A3000%2F%22%2C%22ROOT_URL_PATH_PREFIX%22%3A%22%22%2C%22appId%22%3A%22comzm511li818nx5jr%22%2C%22autoupdateVersion%22%3A%229da5181b237af97fe169a3e1b0ddb7395c68caff%22%2C%22autoupdateVersionRefreshable%22%3A%228e75859990afc3d8c7dcef4ef49fc89515f1f106%22%2C%22autoupdateVersionCordova%22%3A%22none%22%7D"));</script>

  <script type="text/javascript" src="/packages/underscore.js?0a80a8623e1b40b5df5a05582f288ddd586eaa18"></script>
  <script type="text/javascript" src="/packages/meteor.js?43b7958c1598803e94014f27f5f622b0bddc0aaf"></script>
  <script type="text/javascript" src="/packages/json.js?e22856eae714c681199eabc5c0710b904b125554"></script>
  <script type="text/javascript" src="/packages/base64.js?1a63019243b73298e2964e6d4680f25bca657726"></script>
  <script type="text/javascript" src="/packages/ejson.js?71047b64b5196348bdbe5fd5eea9ac97a5a9eb14"></script>
  <script type="text/javascript" src="/packages/logging.js?07e201b648f16be8435a4f666156995eeda0c750"></script>
  <script type="text/javascript" src="/packages/reload.js?da8974b7231dd8c0caccb5f322dcf97329d486d1"></script>
  <script type="text/javascript" src="/packages/tracker.js?6d0890939291d9780f7e2607ee3af3e7f98a3d9c"></script>
  <script type="text/javascript" src="/packages/random.js?fe7b46080c91ce482acf6fc326afbc5b176f0502"></script>
  <script type="text/javascript" src="/packages/retry.js?1f1dd2c35d300110fdaba51ce4473583bc3bf031"></script>
  <script type="text/javascript" src="/packages/check.js?ac81167b8513b85b926c167bba423981b0c4cf9c"></script>
  <script type="text/javascript" src="/packages/id-map.js?9ea6eaae8d74693ce2505a858d9a5e60cf191298"></script>
  <script type="text/javascript" src="/packages/ordered-dict.js?bf8af2f26c8d96bf8b2e6b407d3ed69f23c2cd37"></script>
  <script type="text/javascript" src="/packages/geojson-utils.js?81b79d5cf96d00b4b7a28987debcffb665c17526"></script>
  <script type="text/javascript" src="/packages/minimongo.js?af9eb9d7447544ca9b839a3dcf7ed2da2209b56c"></script>
  <script type="text/javascript" src="/packages/ddp.js?d1840d3ba04c65ffade261f362e26699b7509706"></script>
  <script type="text/javascript" src="/packages/insecure.js?3dc9d4a2dad55999b5b15a447d57f3d5fb66b290"></script>
  <script type="text/javascript" src="/packages/mongo.js?3cfe0c5981c197df33036a37574850f057e934a6"></script>
  <script type="text/javascript" src="/packages/autoupdate.js?9a5ea03bf057815385bf569c7acc2c285c005491"></script>
  <script type="text/javascript" src="/packages/meteor-platform.js?499a2f8522e25820b1153c69a92751ccaae507b3"></script>
  <script type="text/javascript" src="/packages/autopublish.js?c3059a78bb200b171099fc4fa1a9345101790ddb"></script>
  <script type="text/javascript" src="/packages/webapp.js?e1be090051b82f046484dccc2de7d747e50c7328"></script>
  <script type="text/javascript" src="/packages/deps.js?504589e1e9585dec8f9f6094e5a87b22de3783a1"></script>
  <script type="text/javascript" src="/packages/reactive-dict.js?1cb61826ceb23464171f17c2191c7e04a9b91508"></script>
  <script type="text/javascript" src="/packages/session.js?daf192a7244079d45db32a6fc26ebc3881fc1aa3"></script>
  <script type="text/javascript" src="/packages/livedata.js?718526445deb4d9baacb6d92c551adea1d36c1e1"></script>
  <script type="text/javascript" src="/packages/jquery.js?dd8bac56f8fd3666d433d2285ae01e52597cc51a"></script>
  <script type="text/javascript" src="/packages/htmljs.js?567eb96d5d22631c03d6aca6afa4c42f0d1295f2"></script>
  <script type="text/javascript" src="/packages/observe-sequence.js?0532a9dd76dd78f543eb4d79a1e429df186d8bde"></script>
  <script type="text/javascript" src="/packages/reactive-var.js?20335b7b37165980ddd9f23943b2e5b00aae1cc2"></script>
  <script type="text/javascript" src="/packages/blaze.js?a5c324925e5f6e800a4c618d71caf2848b53bf51"></script>
  <script type="text/javascript" src="/packages/ui.js?5a663333fd30f8fd913f110e0ef779e84f67c4b8"></script>
  <script type="text/javascript" src="/packages/templating.js?376767bb0d2463b3b2615a1b90e77f6b22d39d7b"></script>
  <script type="text/javascript" src="/packages/spacebars.js?7bafbe05ec09b6bbb6a3b276537e4995ab298a2f"></script>
  <script type="text/javascript" src="/packages/launch-screen.js?495e58cf2465ba553324c68301cc62076b1fda1e"></script>
  <script type="text/javascript" src="/packages/global-imports.js?ddfcd9be6cef3c8bb0263139937a05092e4a3fe9"></script>
  <script type="text/javascript" src="/template.simple-todos.js?254c6b89dc5850fed9a9e89d00216fdc6b5eeb2e"></script>
  <script type="text/javascript" src="/simple-todos.js?c2e184d448010d8345127ffbaf10ce04b6d355e3"></script>



<title>simple-todos</title>
</head>
<body>

</body>
</html>

So what do you think the problem is?


#2

What browser are you using on Linux Mint?


#3

Firefox, SRWare Iron, and also Google Chrome.
I’ve tried all of those browsers.


#5

I made new installation, and still the same problem.


#6

I tried this

lynx http://localhost:3000    # It display a blank page with title simple-todos

#7
http://localhost:3000

It is still loading even I shut down the server !!!


#8

I tried to install new browser called Maxthon, everything works fine right now with it.
I also tried again with Chrome incognito mode, It works now.

But it still doesn’t work with the normal mode of SRWare Iron, or firefox browser.
Do you think guys this will happened for users when publishing in production ?!

I want to mention another thing.
I have some extensions and plugins installed in Firefox and SRWare Iron browsers, but not in the Google Chrome
Those are AdBlock, Adblock for Youtube, Adblock Plus, and Adblock Pro.

I also tried to disable them, but still exist.


#9

Surprise,
I completed the lessons to deployment lesson, then I found that the website have the same issue, but it worked only in the incognito mode.
Awesome :cry: , really I hoped to be able to build my apps using Meteor.
Anyway I will have a good future, I really hoped to start my first real apps with it.


#10

How long? Can you compare it to something else (say, a popular website one of us could also benchmark, an app deployed on meteor.com, etc)? What hardware do you have (cores, RAM, disk speed)?

I think Meteor fills in that <body> part dynamically. Inspect the JavaScript the app serves, too. The default Meteor app (what you get with meteor create) is meant to work with a thicker client than curl, one that can run JavaScript. For example: a mobile or desktop web browser.


#11

Yes, you’re right I didn’t notice that.

I mean It take long time loading, without any response on the page.

Anyway, I tried opening my deployed app on meteor.com, using Chrome based browsers in Windows 7 and everything works well.

I think the problem with my Firefox, and SRware Iron browsers on Linux Mint, because I installed Maxthon browser on my linux, and every thing works well :slight_smile: :slight_smile:


#12

Also, I’ve tried the local server and the deployed one on meteor.com using Firefox, and SRware Iron in Linux Mint … Everything works fine now :confused:, I don’t know why, but it works.