[SOLVED] Meteor 1.3 running "meteor" runs my tests with the app

Hi, I have the practicalmeteor:mocha package installed and I just update to Metero 1.3 and now when I run meteor I get the following:

=> Started proxy.
=> Started MongoDB.
=> Started your app.

=> App running at: http://localhost:3000/
I20160328-15:41:53.708(2)? MochaRunner.runServerTests: Starting server side tests with run id Jt84Qqr7okswxwvGZ
W20160328-15:41:53.710(2)? (STDERR) MochaRunner.runServerTests: failures: 0

and have the mocha html reporter rendering the results when I scroll to the bottom of my app page.

Is this behaviour intended?


Did you find a solution to this? Seems like utterly bizarre default behaviour!


You’ll need to grab the rc of practicalmeteor:mocha: (meteor add practicalmeteor:mocha@2.1.1-rc.1).

Meteor doesn’t automatically install it as it’s an RC. @rbabayoff will release at 2.1.1 version soon I hope!


1 Like

I had the same issue as the OP and upgrading to this version fixed it for me.

This syntax didn’t work for me, I had to use: meteor add practicalmeteor:mocha@2.1.1-rc.1

1 Like

Thanks @tomRedox - I’ve edited my comment to reflect this

Hey, just published practicalmeteor:mocha@2.1.0_8 for meteor 1.3. You can now just:

meteor add practicalmeteor:mocha
# Or
meteor update practicalmeteor:mocha@2.1.0_8

Note: You will get some “Unable to resolve some modules:” warnings, those are safe to ignore, if their origin is mocha. We’re working on eliminating those.

1 Like

thanks for your replies @tmeasday and @tomRedox and @rbabayoff for the update, great work :smiley: