SOLVED: Meteor Debug in 1.3 not logging


#1

Hi,

I’m trying to debug my server-side code, using meteor debug --debug-port 5000 --settings settings.json, which tells me my application is paused in my terminal and to go to http://localhost:7222/debug?port=5000.

Once there, I can unpause it through node-inspector no problem, however my console.log() and Meteor._debug() statements don’t print out into node-inspectors console. They do however show in my terminal, though they’re objects so I simply see:

{ api: { response: [ [Object] ], user: [ [Object] ] } }

Pretty useless to me, hence trying to get them in node-inspector. Has anyone else encountered this issue? Anyone know a fix?

Cheers


#2

Not straight answer to your question, but bundled node-inspector kinda out of date. I use node-inspector globally installed via npm.

See this thread.


#3

@rmuratov Thank you!


To anyone else running into this issue follow these steps:

npm cache clean
npm uninstall -g node-inspector
npm install -g node-inspector --target=0.10.43

Run your meteor app in debug mode:
env NODE_OPTIONS='--debug-brk' meteor --settings settings.json

Finally in a new terminal window run:
node-inspector and head to the URL it gives you. Both --debug and node-inspector should default to port 5858, they do have override flags if required.