SOLVED: Meteor Iphone 7 Plus mobile-config.js settings launch images not working


#1

Trying to get my new iPhones settings working, this isn’t working:

'iphone6':	'public/images/apps/ios/launch/iphone6.jpg',
'iphone6p_portrait':			'public/images/apps/ios/launch/iphone6p_portrait.jpg',

'iphone7':	'public/images/apps/ios/launch/iphone7_landscape.jpg',
'iphone7_portrait':			'public/images/apps/ios/launch/iphone7_portrait.jpg',
'iphone7p':	'public/images/apps/ios/launch/iphone7plus_landscape.jpg',
'iphone7p_portrait':			'public/images/apps/ios/launch/iphone7plus_portrait.jpg',

#2

What exactly is the problem?


#3

It doesn’t pick up the mobile-config settings, so the launcher is simply the app icon - which totally screwed up the rendering on the device. It doesn’t fill the correct height and so forth.

So what are the correct settings?


#4

I am using this configuration:

App.launchScreens({
  'android_mdpi_portrait': 'private/images/mobile/drawable-mdpi/splash.9.png',
  'android_mdpi_landscape': 'private/images/mobile/drawable-mdpi/splash.9.png',
  'android_hdpi_portrait': 'private/images/mobile/drawable-hdpi/splash.9.png',
  'android_hdpi_landscape': 'private/images/mobile/drawable-hdpi/splash.9.png',
  'android_xhdpi_portrait': 'private/images/mobile/drawable-xhdpi/splash.9.png',
  'android_xhdpi_landscape': 'private/images/mobile/drawable-xhdpi/splash.9.png',
  'android_xxhdpi_portrait': 'private/images/mobile/drawable-xxhdpi/splash.9.png',
  'android_xxhdpi_landscape': 'private/images/mobile/drawable-xxhdpi/splash.9.png',
  'iphone_2x': 'private/images/mobile/iphone_2x.splash.png',
  'iphone5': 'private/images/mobile/iphone5.splash.png',
  'iphone6': 'private/images/mobile/iphone6.splash.png',
  'iphone6p_portrait': 'private/images/mobile/iphone6p_portrait.splash.png',
  'iphone6p_landscape': 'private/images/mobile/iphone6p_landscape.splash.png',
  'ipad_portrait': 'private/images/mobile/ipad_portrait.splash.png',
  'ipad_portrait_2x': 'private/images/mobile/ipad_portrait_2x.splash.png',
  'ipad_landscape': 'private/images/mobile/ipad_landscape.splash.png',
  'ipad_landscape_2x': 'private/images/mobile/ipad_landscape_2x.splash.png'
});

Maybe it’s because you put your images in the public folder instead of the private folder?


#5

Naw everything else works fine. Android is perfect, it’s all in public.

Does your config work for the iPhone 7 and Plus? Maybe my paths are wrong, I’ll double check. When I go in to Xcodes images AppIcon viewer, there’s a lot still showing Cordova / Meteor icons.


#6


#7

I tried in in the simulator, both iPhone 7 and plus work fine.

That some of the icons are still Cordova default icons is a known issue:

Be sure to delete them before submitting your app to the app store. Otherwise, it will be rejected.


#8

Ah for fucks sake, this is the stuff about Meteor that really bothers me. Their main selling feature to chose as a platform are that it exports mobile apps, and features hot code push.

Both are bugged. That costs me friggin douzens of hours each time.

I guess I’ll have to manually import to Xcode… Thanks for your time man, I really really appreciate it.


#9

Glad to hear we’re in the same boat. :frowning: I have the feeling that the Cordova integration is a little bit neglected, to put it politely. Was even wondering if anyone else than me was actively using it, since I ran into so many problems, especially when upgrading my app from 1.2 to 1.5.

BTW: I haven’t seen Martijn in these forums for quite a while. Is he even working on this anymore?!


#10

Alright, I just used https://makeappicon.com to build my icon. Worked perfectly, even generates xCodes manifest file so you can drag and drop your icons in and bam! Let’s see how the app builds…


#11

It’s working on the iPhone 5 emulator… I’ve seen that I may need to remove the .png extensions.

Not working on my actual device.


#12

Strange. I don’t have an actual device, so I can’t compare.


#13

I know. Neither did I until two days ago. Apple is so sexy…

Anyway when I built my app, it spits out in the log: “The splashscreen image name LaunchImage-700 was not found”

So, I’ll fill it in and see how it goes.


#14

I can confirm that Meteor did NOT correctly export the multi-task icon. But going in to xCode after the project was imported and reassigning images works.

Still working on Iphone 7, which seems to be an xcode issue itself, as my iMac is… old.


#15

Very oddly, the simulator shows the correct splash screen. So looks like this is indeed an xcode issue.


#16

Okay, so in addition to Meteor not allowing you to fill in all the blanks to ACTUALLY submit an app properly, my online generator I used to resize 1 master image… was off by 30px on one of the builds.

Ironically on the device I just bought. So I manually built all the images, and BAM, it totally works.

I hope this information helps some one in the future, and that Meteor fixes their export tools asap! But I’ve come to expect this of Meteor. Still, it’s hard to complain, I still view Meteor as ‘new tech’, which always will come with issues. Cheers.