[Solved] Meteor run --production kills iron:router?


#1

I’ve tried to set up an app on node, pretty much following this:

I skipped the step on setting up a service for now, as I wanted to test it first.
Running “node main.js” seems to work fine. Firefox debugger shows CSS is loaded, and looking in to MongoDB, the database init has been performed(Default users in app etc that I used for debugging).

However, Iron Router seems to have issues here. router.js doesn’t seem to be used as / shows the page in the picture below. I tried some of the other known paths in my app to no avail.

I tried running “meteor run --production”. This reproduces the problem.
It runs fine with only “meteor run”. For some reason the minifying kills all routing?

I checked out the code, and the router.js file is loaded just fine in the generated, minified js file.

What could be the problem here?

Solved:

Meh… Apparently two templates were named the same. This was fine in debug but not in production? Strange bug?


#2

Bump for more bug detail. Found out meteor run --production reproduces the error.