[solved] Meteor update crushes my app


#1

Basically, here is the situation:

  1. I’ve run meteor update

  2. Now
    bassfunk|⇒ meteor --version Meteor 1.1.0.3

  3. And
    meteor => Started proxy. => Started MongoDB. => Errors prevented startup: While selecting package versions: error: unknown package: isobuild:minifier-plugin Required by: standard-minifiers 1.0.1 => Your application has errors. Waiting for file change.

  4. I’m failing to understand, what should I do next. Would appreciate any suggestions.


#2

well, it is quite obvious “meteor update” did not finished successfully.
run it again and act based on output it gives.

For example we removed all packages related to less so we can update.
Same goes for removing meteorhacks:npm and npm-container.
Just to be installed back after the core itself updated to 1.2 .


#3

Wow, it did not went well: http://pastebin.com/PPTm3R2S

From what should I start? Is there a way to bring everything back to the METEOR@1.0.1?


#4

I would probably just try to remove
yogiben:autoform-file
yogiben:admin

Than according to meteor help update you can force versions for core and packages separately.
So I would just try to finish upgrading core to 1.2 or I dont know.

Our upgrade yesterday went well.
I heard that yogiben admin is not updated for 1.2 too.


#5

But then i will loose the whole admin interface in my perfectly working app. I thin I need to find a way to downgrade my meteor and all the packages to the 1.0.1 version, when it worked.


#6

Well, you can always restore it from git or whatever you are using.
Or if you are not versioning, create new project, force it to requested version by using meteor update --release ReleaseString .
And copying files plus adding all packages.
Most probably there is also some way how to hack version file in .meteor, but I would not bother with it.

PS: just to be clear, we removed some packages just to do the upgrade and added them back after. Cause they needed it handled this way cause of less package not being backwards compatible. But we are still using them - the new version of them.

And regarding admin interfaces etc. i would expect them to work perfectly fine, maybe you will just need to clone them locally and update version string in package.js.


#7

How do you manage to add them back after update? I’ve now performed meteor remove yogiben:autoform-file && meteor remove yogiben:admin && meteor update and now on 1.2.0.2 version. But when i’m trying to bring them back it give me the same problem

meteor add yogiben:autoform-file
 => Errors while adding packages:             
                                              
While selecting package versions:
error: Conflict: Constraint less@1.0.11 is not satisfied by less 2.5.0_3.
Constraints on package "less":
* less@=2.5.0_3 <- top level
* less@2.5.0_2 <- yogiben:autoform-modals 0.3.8
* less@2.5.0_1 <- accounts-ui 1.1.6
* less@2.5.0_1 <- accounts-ui-unstyled 1.1.8 <- accounts-ui 1.1.6
* less@1.0.11 <- yogiben:autoform-file 0.2.9

UPD: When i’m starting the application it works great except for the admin interface.


#8

Usually I just git clone package into /packages directory, remove git files (cause Webstorm is annoying :smiley: ) and update less required version in their package.js


#9

I’ve meteor add yogiben:admin and it works great on 1.2.0.2, thanks!