[solved] Metor update from 1.6.0.1 to latest version (1.7.0.3) error: Conflict: Constraint babel-compiler@6.19.4 is not satisfied by babel-compiler 7.1.1

I have tried updating in several ways
meteor update
meteor update --patch
meteor update --release 1.7.0.3
all of them throw the same error

=> Errors while initializing project:

While selecting package versions:
error: Conflict: Constraint babel-compiler@6.19.4 is not satisfied by babel-compiler 7.1.1.
Constraints on package “babel-compiler”:

  • babel-compiler@~7.1.1 <- top level
  • babel-compiler@7.1.0 <- ecmascript 0.11.1
  • babel-compiler@7.0.0 <- minifier-js 2.3.5 <- standard-minifier-js 2.3.4
  • babel-compiler@6.19.4 <- coffeescript-compiler 1.12.7_3 <- coffeescript 1.12.7_3
  • babel-compiler@7.0.8 <- standard-minifier-js 2.3.4

I also tried meteor add babel-compiler@~7.1.1 and I got the same error

any suggestions about updating my app

PS: I also did meteor npm install @babel/runtime

I was able to update my app by only removing coffeescript

2 Likes

hey i have actually the same kind of error , please how did you remove coffescript . I searched everywhere and tried npm -g uninstall coffescript and npm uninstall coffescript , but i still get the same kind of error. Thanks in advance

Focus on this:

error: Conflict: Constraint babel-compiler@6.19.4 is not satisfied....

babel-compiler@6.19.4

Then look in your list, OP was like this:

  • babel-compiler@~7.1.1 <- top level
  • babel-compiler@7.1.0 <- ecmascript 0.11.1
  • babel-compiler@7.0.0 <- minifier-js 2.3.5 <- standard-minifier-js 2.3.4
  • babel-compiler@6.19.4 <- coffeescript-compiler 1.12.7_3 <- coffeescript 1.12.7_3
  • babel-compiler@7.0.8 <- standard-minifier-js 2.3.4

babel-compiler@6.19.4 <- coffeescript-compiler …

So coffeescript-compiler is unhappy

In your system, it might be something else

1 Like

I did meteor remove coffeescript

That is not always possible since coffeescript is often a dependency

A way to see which component uses what, is:
meteor list --tree

1 Like

How you solved it please share solution. Thanks in advance.

The solution was shared here:


and here:

With a great tip for finding other packages that depend on coffeescript here:

meteor update
=> Errors while initializing project:

While selecting package versions:
error: Conflict: Constraint babel-compiler@6.19.4 is not satisfied by babel-compiler 7.1.1.
Constraints on package “babel-compiler”:

  • babel-compiler@~7.1.1 <- top level
  • babel-compiler@7.1.0 <- ecmascript 0.11.1
  • babel-compiler@7.0.0 <- minifier-js 2.3.5 <- standard-minifier-js 2.3.4
  • babel-compiler@7.0.8 <- standard-minifier-js 2.3.4
  • babel-compiler@6.19.4 <- coffeescript-compiler 1.12.7_1 <- coffeescript 1.12.7_1 <- juto:jessepollack-card 1.0.0

meteor remove coffeescript
coffeescript is not a direct dependency in project.

But yes after running meteor list --tree, got 4 dependencies. But how can I remove it and if I do so, it will affect the npm packages which are using them. So what to do?

juto:jessepollack-card@1.0.0
├─┬ coffeescript@1.12.7_1
│ ├── babel-runtime@1.0.1 (expanded above)
│ ├── caching-compiler@1.1.9 (expanded above)
│ ├─┬ coffeescript-compiler@1.12.7_1

mizzao:user-status@0.6.7
├── accounts-base@1.3.4 (top level)
├── check@1.2.5 (expanded above)
├── coffeescript@1.12.7_1 (expanded above)

ostrio:files@1.8.3
├── check@1.2.5 (expanded above)
├── coffeescript@1.12.7_1 (expanded above)

You will need to update or replace those packages.

ostrio:files can just be updated, newer versions have removed the coffeescript dependency

For the other two, since there’s no updates for them, the usual approach is to download the package and include it in your project under /packages/. This will allow you to make local modifications that will be used instead of the online version.

The simplest way to update these is to compile the coffeescript files to plan JS and replace them in the package. Then remove the coffeescript dependency

Alternatively, you might decide it’s just not worth the effort and stay on Meteor 1.6!

2 Likes

@coagmano I reinstalled ostrio:files as yo said the latest version is not using coffeescript. Removed juto:jessepollack-card as it was unnecessary. Then updated my meteor by using meteor update. And it worked like charm. Then got error of babel, so ran command meteor npm install @babel/runtime@7.0.0-beta.55. And everything is sorted now. Thank you so much.

1 Like

This is how I solved the constraint problem. Note: I’m updating from 1.5.x to 1.6.x:

meteor remove coffeescript
meteor update --release 1.6.1
meteor add coffeescript