[SOLVED] MUP change in behavior, local database not deployed?


#1

I have been using Meteor for projects for about a year now, successfully. Love the framework and how it integrates so well with React.js.

However, yesterday I ran into an issue I had not previously encountered. I configured mup.js as usual. I have used the built-in mongodb instance for many projects and have never had to change the MONGO_URL configuration.

To my surprise, the database is nowhere to be found on the staging server and as such none of the data in the database appears on the site. I went down a rabbit hole of configuring mongodb on different Digital Ocean Ubuntu Droplets of varying sizes and configurations. Securing the server, creating an admin profile on the remote db, changing the firewall settings, adding the mongodb://username:password@server_ip:27107/meteor line to MONGO_URL, only to receive the infamous MongoError: failed to connect to server [server_ip:27017] on first connect [MongoError: connect ECONNREFUSED server_ip:27017] error on the Verifying Deployment step, which has about 4-5 open issues on the MUP GitHub repo.

I have tried the old abernix docker container as well as the newere zodern docker container to no avail.

I can’t seem to find the right combination of commands to mongodump from the local database and mongorestore to the remote database.

I’ve looked through the configurations of my other, successfully deployed Meteor Apps that are using the built-in database and I can’t find any issues with my mup.js configuration. The MUP docs seem to be either conflicting, out of date, or both.

Needless to say, I’m stumped. I feel like I’ve tried everything twice, and I’m hoping that the community here can lend a hand.

Let me know if it this is a duplicate (although I feel like I have searched far and wide) and please don’t hesitate to request more information about this issue, if I missed some details.

Thanks in advance!


#2

Ok, so it took some deep searching through a bunch of piecemeal StackOverflow entries but I finally solved this issue.

I created this gist in case anyone else encounters the issue.