[SOLVED] Mup-classic errors


#1

I’m trying to get mup-classic (a version of mup that’s non-docker) that’s a spinoff of 0.11.3 to work with Meteor 1.3.5.1.

For some reason the fork of mup won’t deploy (install works), I get the following error:

Invoking deployment process: FAILED

-----------------------------------STDERR-----------------------------------
hine please make sure you have setup your
build environment--
Windows + OS X instructions here: https://github.com/nodejs/node-gyp
Ubuntu users please run: `sudo apt-get install g++`
Alpine users please run: `sudo apk add python make g++`
sh: 1: nodejs: not found

npm ERR! fibers@1.0.13 install: `node build.js || nodejs build.js`
npm ERR! Exit status 127
npm ERR!
npm ERR! Failed at the fibers@1.0.13 install script.
npm ERR! This is most likely a problem with the fibers package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node build.js || nodejs build.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls fibers
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 3.13.0-36-generic
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! cwd /opt/fp-development/tmp/bundle/programs/server
npm ERR! node -v v0.10.43
npm ERR! npm -v 1.4.29
npm ERR! code ELIFECYCLE
npm ERR! not ok code 0
-----------------------------------STDOUT-----------------------------------
 > ./bcrypt: npm install due to binary npm modules
bindings@1.2.1 node_modules/bindings

nan@2.2.1 node_modules/nan

nodeunit@0.9.1 node_modules/nodeunit
└── tap@0.7.1 (inherits@2.0.1, buffer-equal@0.0.2, slide@1.1.6, deep-equal@1.0.1, yamlish@0.0.7, nopt@3.0.6, mkdirp@0.5.1, difflet@0.2.6, glob@4.5.3, runforcover@0.0.2)
make: Entering directory `/opt/fp-development/tmp/bundle/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/bcrypt/build'
  CXX(target) Release/obj.target/bcrypt_lib/src/blowfish.o
  CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt.o
  CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt_node.o
  SOLINK_MODULE(target) Release/obj.target/bcrypt_lib.node
  COPY Release/bcrypt_lib.node
make: Leaving directory `/opt/fp-development/tmp/bundle/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/bcrypt/build'

> fibers@1.0.13 install /opt/fp-development/tmp/bundle/programs/server/node_modules/fibers
> node build.js || nodejs build.js

----------------------------------------------------------------------------

I ran the command sudo apt-get install g++ and got the same error.

Here is my mupc.json:

{
  // Server authentication info
  "servers": [
    {
      "host": "ipaddress",
      "username": "username",
      "pem": "/Users/myname/Meteors/pem.pem"
    }
  ],


  // Install MongoDB in the server, does not destroy local MongoDB on future setup
  "setupMongo": false,

  // WARNING: Node.js is required! Only skip if you already have Node.js installed on server.
  "setupNode": true,

  // WARNING: If nodeVersion omitted will setup 0.10.33 by default. Do not use v, only version number.
  "nodeVersion": "0.10.43", // changed from 35 to 36

  // Install PhantomJS in the server
  "setupPhantom": false,

  // Application name (No spaces)
  "appName": "fp-development",

  // Location of app (local directory)
  "app": "/Users/myname/Meteors/clients-workstation",

  // Configure environment
  "env": {
    "PORT": "80",
    "ROOT_URL": "https://mydomain.com", // change to https
    "MONGO_URL": "mongodb://creds@location.mlab.com:port/db"
  },

  // Meteor Up checks if the app comes online just after the deployment
  // before mup checks that, it will wait for no. of seconds configured below
  "deployCheckWaitTime": 80,

  "enableUploadProgressBar": true
}

If I do a node -v on the box: v0.10.43 and npm -v: 1.4.29


UPDATE: Seems this command got me over the hump (but I did a few things so this might not be all of it):

sudo apt-get install -y python2.7-minimal
cd /usr/bin && ln -s python2.7 python


I haven’t tested everything, but I think I’ve successfully installed 1.3.5.1 with meteor-up-classic.


#2

I forked arunoda’s meteor-up (it is abandoned, with the last version here was 0.11.3 and created a brand new repo that picks up where it left off – namely supporting 1.2 + deployments without docker. I called it meteor-up-classic. I’ve successfully gotten 1.3.5.1 running using mup-classic (where as arunoda’s mup doesn’t support anything above meteor 1.2).

Of course if you need or want docker, kadirahq’s meteor-up is where the new development is taking place. In my case I can’t use docker because I need access to the file system (read/write/delete dirs and files) OUTSIDE of the Meteor application and don’t know enough about docker to configure that (and don’t have the cycles to figure it out right now) – hence meteor-up-classic.