[SOLVED] My app crashes after updating to V1.5.1

I just updated to Meteor 1.5.1 from and now my app (which was running fine on crashes with:

W20170713-10:12:53.353(2)? (STDERR) /Users/willem/.meteor/packages/meteor-tool/.1.5.1.rx70nv++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:280
W20170713-10:12:53.354(2)? (STDERR) 						throw(ex);
W20170713-10:12:53.356(2)? (STDERR) 						^
W20170713-10:12:53.358(2)? (STDERR) 
W20170713-10:12:53.360(2)? (STDERR) TypeError: Cannot read property 'resolve' of undefined
W20170713-10:12:53.361(2)? (STDERR)     at meteorInstall.node_modules.meteor.shell-server.shell-server.js (packages/shell-server/shell-server.js:370:26)
W20170713-10:12:53.362(2)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:341:9)
W20170713-10:12:53.362(2)? (STDERR)     at require (packages/modules-runtime.js:236:16)
W20170713-10:12:53.363(2)? (STDERR)     at meteorInstall.node_modules.meteor.shell-server.main.js (packages/shell-server/main.js:1:14)
W20170713-10:12:53.363(2)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:341:9)
W20170713-10:12:53.365(2)? (STDERR)     at require (packages/modules-runtime.js:236:16)
W20170713-10:12:53.366(2)? (STDERR)     at /Users/willem/meteor/youtopx3/.meteor/local/build/programs/server/packages/shell-server.js:568:15
W20170713-10:12:53.367(2)? (STDERR)     at /Users/willem/meteor/youtopx3/.meteor/local/build/programs/server/packages/shell-server.js:574:3
W20170713-10:12:53.367(2)? (STDERR)     at /Users/willem/meteor/youtopx3/.meteor/local/build/programs/server/boot.js:338:34
W20170713-10:12:53.368(2)? (STDERR)     at Array.forEach (native)
=> Exited with code: 1

Any idea where I should look?

remove your node module and npm install again

I have removed my node_modules folder (and .meteor/local) but no success; the error remains the same…

Also, if I create a new meteor project (meteor create test) and try to run it, the same error happens…

I think this is related to this:

At the moment 1.5.1 has not been marked as recommended, which means that when you do meteor create test you will be using the latest recommended version (1.5.0). However, the above post says that the packages will have been updated, but not the build. So, you could update your test:

cd test
meteor update --release 1.5.1

and/or run with the release flag:

cd test
meteor --release 1.5.1

I tried both your options, however, the error remains the same.

Interesting. I was only able to replicate (and fix) your issue as I described. Maybe something else going on in there.

Please have a look to this thread. [SOLVED]Meteor upgrade to 1.5 error:Uncaught ReferenceError: Buffer is not defined

Not sure what you want me do with the advice in this thread you are referring to…
I don’t think I should have to modify my app to get Meteor working again?
Something must have gone wrong during the update process, but here were no errors of any kind.

I completely uninstalled meteor (removed /usr/local/bin/meteor and ~/.meteor) and reinstalled meteor again which gave me V1.5
Now I can create new 1.5 projects and run them ok.
I restored a backup for my V1.4.4.3 app (which still runs fine) and did a meteor update in the app-folder.
This is what happened:

meteor update
Changes to your project's package version selections from updating the release:
accounts-base              upgraded from 1.2.17 to 1.3.0
accounts-google            upgraded from 1.1.2 to 1.2.0
babel-compiler             upgraded from 6.18.2 to 6.19.1
boilerplate-generator      upgraded from 1.0.11 to 1.1.0
dynamic-import             added, version 0.1.0
ecmascript                 upgraded from 0.7.3 to 0.8.0
ecmascript-runtime         upgraded from 0.3.15 to 0.4.1
ecmascript-runtime-client  added, version 0.4.1
ecmascript-runtime-server  added, version 0.4.1
localstorage               upgraded from 1.0.12 to 1.1.0
meteor-base                upgraded from 1.0.4 to 1.1.0
minifier-js                upgraded from 2.0.0 to 2.1.0
minimongo                  upgraded from 1.0.23 to 1.2.0
modules                    upgraded from 0.8.2 to 0.9.0
modules-runtime            upgraded from 0.7.10 to 0.8.0
mongo                      upgraded from 1.1.17 to 1.1.18
promise                    upgraded from 0.8.8 to 0.8.9
standard-minifier-js       upgraded from 2.0.0 to 2.1.0
webapp                     upgraded from 1.3.15 to 1.3.16

youtopx3: updated to Meteor 1.5.              
Changes to your project's package version selections from updating package versions:
accounts-password          upgraded from 1.3.6 to 1.3.7
babel-compiler             upgraded from 6.19.1 to 6.19.4
boilerplate-generator      upgraded from 1.1.0 to 1.1.1
ddp-common                 upgraded from 1.2.8 to 1.2.9
dynamic-import             upgraded from 0.1.0 to 0.1.1
ecmascript                 upgraded from 0.8.0 to 0.8.2
ecmascript-runtime-client  upgraded from 0.4.1 to 0.4.2
email                      upgraded from 1.2.1 to 1.2.3
localstorage               upgraded from 1.1.0 to 1.1.1
meteor                     upgraded from 1.6.1 to 1.7.0
minifier-js                upgraded from 2.1.0 to 2.1.1
minimongo                  upgraded from 1.2.0 to 1.2.1
modules                    upgraded from 0.9.0 to 0.9.2
npm-bcrypt                 upgraded from 0.9.2 to 0.9.3
shell-server               upgraded from 0.2.3 to 0.2.4
standard-minifier-js       upgraded from 2.1.0 to 2.1.1
webapp                     upgraded from 1.3.16 to 1.3.17

The following top-level dependencies were not updated to the very latest version available:
 * accounts-password 1.3.7 (1.4.0 is available)
 * mongo 1.1.18 (1.1.19 is available)         
Newer versions of the following indirect dependencies are available:
 * accounts-base 1.3.0 (1.3.1 is available)   
 * allow-deny 1.0.5 (1.0.6 is available)      
 * coffeescript 1.0.17 (1.12.6_1 is available)
 * ddp 1.2.5 (1.3.0 is available)             
 * ddp-client 1.3.4 (2.0.0 is available)      
 * ddp-server 1.3.14 (2.0.0 is available)     
These versions may not be compatible with your project.
To update one or more of these packages to their latest
compatible versions, pass their names to `meteor update`,
or just run `meteor update --all-packages`.
kantoor:youtopx3 willem$ meteor --settings settings.json
[[[[[ ~/meteor/youtopx3 ]]]]]                 

=> Started proxy.                             
=> Started MongoDB.                           
W20170713-19:53:22.978(2)? (STDERR) /Users/willem/.meteor/packages/meteor-tool/.1.5.0.edxpxb++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:280
W20170713-19:53:23.048(2)? (STDERR) 						throw(ex);
W20170713-19:53:23.049(2)? (STDERR) 						^
W20170713-19:53:23.050(2)? (STDERR) 
W20170713-19:53:23.051(2)? (STDERR) TypeError: Cannot read property 'get' of undefined
W20170713-19:53:23.053(2)? (STDERR)     at withoutInvocation (packages/meteor.js:443:33)
W20170713-19:53:23.054(2)? (STDERR)     at bindAndCatch (packages/meteor.js:452:33)
W20170713-19:53:23.054(2)? (STDERR)     at Object._.extend.defer (packages/meteor.js:514:26)
W20170713-19:53:23.055(2)? (STDERR)     at [object Object].MongoConnection.tail (packages/mongo/mongo_driver.js:1170:10)
W20170713-19:53:23.055(2)? (STDERR)     at [object Object]._.extend._startTailing (packages/mongo/oplog_tailing.js:239:50)
W20170713-19:53:23.056(2)? (STDERR)     at new OplogHandle (packages/mongo/oplog_tailing.js:76:8)
W20170713-19:53:23.057(2)? (STDERR)     at new MongoConnection (packages/mongo/mongo_driver.js:214:25)
W20170713-19:53:23.057(2)? (STDERR)     at new MongoInternals.RemoteCollectionDriver (packages/mongo/remote_collection_driver.js:4:16)
W20170713-19:53:23.058(2)? (STDERR)     at Object.<anonymous> (packages/mongo/remote_collection_driver.js:38:10)
W20170713-19:53:23.059(2)? (STDERR)     at Object.defaultRemoteCollectionDriver (packages/underscore.js:784:19)
=> Exited with code: 1

still no luck…

The error:

TypeError: Cannot read property 'get' of undefined

is fixed by the instructions in the post above:

meteor update --release 1.5.1

@coagmano: that did the trick. All is well now.
Still it leaves me somewhat confused, because this is just what I did to start with.
But never mind…
Thanks everyone!

Can confirm. Had the exact same problem this morning and meteor update --release 1.5.1 fixed it.

Can someone please make version 1.5.1 the recommended version?

Version 1.5.1 isn’t a working solution for us, see the problem here: Undefined variable when debugging on Webstorm strange behavior

We try to get back to but because of this problem we can’t get our code to run. We have a demo to https://www.23andme.com in 2 days. I should have never followed the advice to upgrade to the latest version.