[SOLVED]No plugin found for accounts_ui.styl in ian:accounts-ui-bootstrap-3;


#1

Hello everyone,

I am learning Meteor by following the microscope tutorial through the book. In ‘Adding User’ chapter, it is said that I should write

meteor add ian:accounts-ui-bootstrap-3 and
meteor add accounts-password consecutively

After I wrote meteor add ian:accounts-ui-bootstrap-3 down, everything seemed to be okay

However, I encounter the following problem

Thus I also encounter some problems as well when I try to run afterwards

meteor add accounts-password

What may cause this problem?

Best regards


#2

It looks like the Stylus dependency is missing. Try adding a Stylus package to your project - for example:

meteor add stylus

#3

I change the order of adding packages (I added stylus first after your feedback) and somehow it worked :slight_smile: Thanks


#4

Very strange error indeed… I was searching for a while how to solve this but and in the end it was as simple as removing both ian:accounts-ui-bootstrap-3 and accounts-password, adding stylus and then adding the others again.

Thanks for sharing!


#5

Thank you, your solution worked for me.


#6

Thanks guys! Just encountered the same issue and this worked!


#7

this is also works for me, but you can also go to .meteor folder and then open packages file. here you can edit it by hand or doing remove manually in command line.


#8

Worked for me! Thanks