[solved] Problem building/deploing with Meteor 1.6.1 and CoffeeScript


#1

As in (https://guide.meteor.com/deployment.html) from my project directory I run:
meteor npm install --production
meteor build ../build --architecture os.linux.x86_64
This spits out: Node#moveTo was deprecated. Use Container#append.

When I now untar the created meteor.tar.gz the file programs/server/main.js so there is no way to start the app with plain node.

There is a file programs/server/app/app.js when I try to run node app.js I get
``meteor://:computer:app/app/app.js:1
(function (exports, require, module, __filename, __dirname) { var require = meteorInstall({“lib”:{“collections.coffee”:function(){
^

ReferenceError: meteorInstall is not defined```.

I’m not sure if the tar was not build correctly (main.js should be there) or if the documentation is not updated and I have another problem with CoffeeScript (installed with meteor add coffeescript). Any ideas?


#2

I misread the deployment guide. main.js is created at the root level not under programs/server.