[SOLVED]: Problem deploying to Galaxy or DO+mup


I have an app running for month now on DO+mup. It worked great, but now I’m unable to start the app. This is the end of the log:

+-- type-of@2.0.1 
`-- underscore@1.5.2 

npm WARN meteor-dev-bundle@0.0.0 No description
npm WARN meteor-dev-bundle@0.0.0 No repository field.
npm WARN meteor-dev-bundle@0.0.0 No license field.
=> Starting meteor app on port:80
=> Redeploying previous version of the app

To see more logs type 'mup logs --tail=50'

(node:28585) DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

As it’s urgent to start it again, I’ve tried to deploy the app to galaxy. The end of the logs:

2017-02-09 12:14:45+01:00Successfully built 86f02927b454
2017-02-09 12:14:45+01:00Pushing image to Galaxy's Docker registry.
2017-02-09 12:15:07+01:00Cleaning up.
2017-02-09 12:15:08+01:00Successfully built version 1.
2017-02-09 12:15:32+01:00Application process starting, version: 1 on apprunner (embedded)

But when I try to reach it all I get is:

503 Service Unavailable: No healthy endpoints to handle the request.

It seems the app can’t start but I don’t see any errors and I’m able to run it locally. Any suggestions?
meteor and mup updated to the latest versions.

What’s even more interesting is that I tried to redeploy a previous version and I get the same error (app never starts). I haven’t changed anything in the server.

Ah, it was a mix: the problem was a cron which called a method which failed constantly, and the error from the mup deploy command gave me the wrong idea.