[SOLVED] Problem with fibers after update from 2.5 to 2.5.1

Hi, after update and release meteor app from 2.5 to 2.5.1 I have following error:

There is an issue with node-fibers

App *** output: /var/www/****/bundle/programs/server/node_modules/fibers/bin/linux-x64-83-glibc/fibers.node is missing.

After downgrade back to meteor 2.5, the problem was solved. I’m running in production Ubuntu 20.04, Apache and nvm. Node version is: v14.18.1

Thanks a lot for each help :slight_smile:

You need to rebuild your node modules in the deployed platform. Our current version of fibers is not including all binaries it did. We will release a new dev bundle soon with all binaries included, in the meanwhile, you have to build it in your server by running a new npm install or npm rebuild.

1 Like

It explains why I don’t have that problem. I’m using Ubuntu 20.04 as dev machine.

npm install did not helped, npm rebuild solved the problem (bud during the rebuild there are some warnings):

../src/fibers.cc:355:87: warning: cast between incompatible function types from ‘uni::FunctionType (*)(v8::Local<v8::String>, const GetterCallbackInfo&)’ {aka ‘void (*)(v8::Local<v8::String>, const v8::PropertyCallbackInfo<v8::Value>&)’} to ‘v8::AccessorNameGetterCallback’ {aka ‘void (*)(v8::Local<v8::Name>, const v8::PropertyCallbackInfo<v8::Value>&)’} [-Wcast-function-type]
  355 |   object->SetAccessor(isolate->GetCurrentContext(), name, (AccessorNameGetterCallback)getter, (AccessorNameSetterCallback)setter).ToChecked();
      |                                                                                       ^~~~~~
../src/fibers.cc:355:123: warning: cast between incompatible function types from ‘void (*)(v8::Local<v8::String>, v8::Local<v8::Value>, const SetterCallbackInfo&)’ {aka ‘void (*)(v8::Local<v8::String>, v8::Local<v8::Value>, const v8::PropertyCallbackInfo<void>&)’} to ‘v8::AccessorNameSetterCallback’ {aka ‘void (*)(v8::Local<v8::Name>, v8::Local<v8::Value>, const v8::PropertyCallbackInfo<void>&)’} [-Wcast-function-type]
  355 |   object->SetAccessor(isolate->GetCurrentContext(), name, (AccessorNameGetterCallback)getter, (AccessorNameSetterCallback)setter).ToChecked();

Is it something wrong?

@minhna …on dev machine, I also don’t have problem, only on production, what is not so important :smiley: :smiley: :smiley:

I build the production bundle on my dev machine then upload the bundle to the production machine which also runs Ubuntu 20.04 :slight_smile:

…and after copy the bundle into production server an unpack the tar file, how you are installing npm in production server (…programs/server)? you write “npm install” or “npm install --production”?

Thanks a lot :slight_smile:

I’m sorry. You’re right. running production has problem.