[Solved] Problem with NPM-packages on Windows 7


#1

I am trying to use different NPM-packages (steam, cheerio, … ) in a package:

Npm.depends({
    "steam": "0.6.7",
    "dota2": "0.6.2",
    ...
});

But when I start meteor I always get this:

npm ERR! protobuf@0.11.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the protobuf@0.11.0 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the protobuf package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls protobuf
npm ERR! There is likely additional logging output above.

The same occurs if I am using meteorhacks:npm to add the packages directly to my application.
Does someone has an idea how to solve this?


#2

I hope this is something when trying to build some binary modules.

You may need to install python and visual studio express as listed here: https://github.com/TooTallNate/node-gyp#installation


#3

Thanks, but that didnt help :frowning:


#4

This seems like a node question in general. Do these packages work just fine in a regular nodejs app (using the same exact version numbers)?


#5

Ups, totally forgot this topic! The problem is solved :smiley:


#6

What was the problem and how did you solve it. I am having the same issue. Help please.


#7

I am not 100% sure … I installed Phyton 2.7.3 and Microsoft Visual Studio 2012. So I guess, arunodas suggestion worked.


#8

see also Error while updating to Meteor 1.4