[SOLVED] Semantic UI - Custom Site Theme No Longer Working


#1

I’d normally ask a question on Stack, but this is a pretty broad question and been stuck for a while now.

I’m using semantic ui, and have been building my app for several months. I have some default variables overridden in the /site/globals/site.variables.imports.less, such as the default color (@primaryColor, @brown, etc.).

Everything has been working fine and I haven’t made any major changes to my site’s theme in a few weeks, but this morning I did meteor run, and the theme has reverted back tot he default semantic ui theme, with the standard colors, etc. I’ve tried regenerating everything by changing the custom.semantic.json and .custom.semantic.json to regenerate the files, but to no avail.

I’ve been searching for a fix to this for the past few hours with no luck. As far as I recall, I didn’t change any settings, or install any packages, or make any major changes that would cause any issues. Can anyone point me in the right direction? Is there a way to regenerate my custom theme, or maybe some logs of why the custom theme’s not working?

Thanks!


#2

how to you have semantic-ui installed? did you use a package?

You might want to cross-post here


#3

I’m using the default atmosphere package: https://atmospherejs.com/semantic/ui


#4

… and I managed to fix it!

Doing some more research, I found this: https://github.com/Semantic-Org/Semantic-UI-Meteor

On there, it has some different instructions than what’s on atmosphere. Here’s what I did to get it working:

remove standard-minifier-css, and flemay:less-autoprefixer
add juliancwirko:postcss, and less

update package.json as the link states to:

{
  "devDependencies": {
    "autoprefixer": "^6.3.1"
  },
  "postcss": {
    "plugins": {
      "autoprefixer": {"browsers": ["last 2 versions"]}
    }
  }
}

After doing an npm install, restarting meteor, the semantic-ui files regenerated as expected.

I’m not sure why it was working fine all this time and suddenly stopped working, but hopefully this will help someone out if they run into the same problem.

Thanks.