[Solved] => Server modified -- restarting


I have the message in the subject but without any indications about what has been modified.
How can i be able to know that?

It is happened when running on Actions Github.


1 Like

Hey @harry73, could you mind sharing more data about what happened? Can you provide a reproduction so that we can test on top of it?

Hi @grubba ,

Thanks for your answer.
In fact i am running Meteor 3 beta 4 with meteor-vite from @jorgenvatle with vue3. I am trying to setup Cypress tests but when the ‘cypress run’ starts on Github via Actions i have this message and vite restarting also. It happened several times and my tests failed (white screen).
Locally, it works, even by removing the node_modules/.vite folder.

As i do not know if it was working on Meteor 2. The tests are new, i wanted to go deeper in the analyzis (peharps something in my code) before bother you. It was the aim of my question.

I will try to see if i can manage to reproduce the issue on a simple project.

1 Like

Maybe it can do something with your global meteor installation(in the CI)

No worries about bothering me; you can always ping us on Slack, and maybe someone there can help, too.

The test/action might be creating/updating a file somewhere in your project directory.

Hey there. Are you still having issues with this? :eyes:

Hi @grubba, @jorgenvatle

Please check the following repo where I am able to reproduce the issue:

Locally, meteor npm start and then meteor npm test work well.

On Github, it fails.


Hi @grubba, @jorgenvatle

Did you find something?


Haven’t yet had the chance to look into it. Wanted to check now, but it seems Atmosphere.js is down at the moment. :worried:

I recall having a similar issue when getting the Svelte example set up. Vite would convert your Vite config from .js to a timestamped .mjs file, and Meteor would trigger a restart every time the file was added, in turn creating another .mjs file on next startup.

Thanks for setting up a repo reproducing the issue. :raised_hands:

I tried also to use GitHub - bluwy/vite-plugin-warmup: Warm up Vite's transform cache but the result is the same: locally it is ok, actions github it fails.
For mjs, i think i tried to have the vite config directly in mjs (because of some options) but same result :pensive:


Did you have chance to look at it ?

Do you need something from me ?


Hey @harry73. :wave:

Just had a few hours to look into it. Seems like Cypress isn’t able to connect to the Vite dev server when running in GitHub Actions. I had similar issues trying to run the repository in GitHub Codespaces. Calling Vite from within the GitHub container works fine, but proxied connections appear to be flaky.

I’ll follow up later this afternoon if anything comes up. :+1:

Seems like Cypress really doesn’t like it when Vite triggers a client refresh.

Made some changes to try to run dependency optimization before Cypress accesses the app.

The Meteor server restarts were just from summary files being added to your Cypress directory. Excluding them with a .meteorignore file seems to have done the trick there.

I submitted a pull request with what I did so you can get a better insight into what changes were necessary to get it to run.


Now, the server does not restarted any more on GitHub

On the repo that reproduicing the issue, everything works well.

My project, unfortunately, on Github, the tests are failing.

Locally, everything is OK, but not with GitHub Actions. Il is like the Application is not loaded (white page).

When I look at Cypress Replay, I can see that there is no answers for:




Locally, it is OK:



Also on Actions GitHub, I do not see this request:


I forgot to mention. I use:

Meteor 3 beta 6
Vite-bundle 2.0.0 beta 11
Meteor-vite 1.10.2

Can you try with jorgenvatle:vite-bundler@2.0.0-beta.12? And let’s set an explicit hostname for the Vite client entry script - set METEOR_VITE_HOST=localhost in your Meteor start script. This should ensure the HTML served by Meteor won’t point the Cypress client to the Vite dev server on an invalid IP.

Also make sure server.host is set to true in your Vite config. I recall this being an issue with default options, even for connections on localhost when running inside of GitHub’s environment.

If there’s no luck with that, would you be able to update the example repo with a way to reproduce the issue? :pray:


It works!!

Thanks for your time.