[solved] Some package update completely breaks my app (cannot find module core-js)


#1

So I did a standard meteor update:

iMac:app patrick$ meteor update
This project is already at Meteor 1.6.1, the latest release.

Changes to your projects package version selections from updating package versions:

accounts-password          upgraded from 1.5.0 to 1.5.1
babel-compiler             upgraded from 7.0.0 to 7.0.5
base64                     upgraded from 1.0.10 to 1.0.11
cultofcoders:grapher       upgraded from 1.3.1 to 1.3.2
ecmascript                 upgraded from 0.10.0 to 0.10.5
ecmascript-runtime-client  upgraded from 0.6.1 to 0.6.2
meteor                     upgraded from 1.8.2 to 1.8.4
minifier-css               upgraded from 1.3.0 to 1.3.1
minifier-js                upgraded from 2.3.1 to 2.3.3
modules                    upgraded from 0.11.3 to 0.11.5
mongo                      upgraded from 1.4.3 to 1.4.5
ostrio:files               upgraded from 1.9.6 to 1.9.8
promise                    upgraded from 0.10.1 to 0.10.2
rate-limit                 upgraded from 1.0.8 to 1.0.9
standard-minifier-css      upgraded from 1.4.0 to 1.4.1
standard-minifier-js       upgraded from 2.3.1 to 2.3.2
xolvio:cleaner             upgraded from 0.3.1 to 0.3.3

After this update, my complete app is broken. The dev server starts up properly, no errors but on the frontend the console is full of errors:

As you can see the whole build process is kinda failing … never experienced this. Any ideas?

Thanks! best, P


#2

Looks like core-js is missing from your node_modules

Should be able to fix with a

meteor npm install core-js

Or worst case, blast your node_modules folder and then install:

rm -rf node_modules
meteor npm install core-js
meteor npm install

Now why core-js suddenly went missing i can’t tell :man_shrugging:


#3

I had the same issue when I updated to 1.6.1, core-js went missing!


#4

Thanks guys, will try this asap! Very weird though … I obviously did not npm remove core.js or anything like that so its really odd why it went missing in the first place …


#5

core-js is listed as a dependency with the @babel/runtime package, so I’m not sure why it’s not getting installed…


#6

meteor npm install core-js --save fixed it!