[SOLVED] Total n00b-question here :-) trying Meteoris, getting 403 on new page


#1

Hi everybody,

I’m trying to get into Meteor - so far I am very excited!
I thought I start by using Meteoris, as it seems a nice boilerplate/CRUD starting point. ;I’ve succeeded in getting some collections working already :smile:
But now I am trying to copy the sites, huh, page, I guess you could call it.

I copied: the template, the router, and the controller, basically only cnangeing the name where I thought I should. I then added the link to this all to the header-template, in order for it to display on the page - and it did :smile:
But when I click on it Meteoris gets unfriendly: it says 403 - forbidden. Which is strange, as I am logged in and all. As far as I can tell, the page does not require any special rights, as the sites-page (homepage) does not either.

How can I go about debugging this? In the server-log there is nothing to be seen; no error at least… where to look?

Thanks for any tips,

Paul


#2

Well, I don’t suppose you get points for answering your own question, but just for the sake of completeness… I did not know yes about Meteoris permission system. I added a “collection” with the name of my page, and added the index-action to my user - and it worked!
I do not, at the moment, particularly like the name “collection” for this function, as my page is no collection, but rather a holder-page where I plan to load data from several (db-)collections. But I followed the trail witing Meteor(is) to solve this, so I feel good about that anyway :sunny: