[SOLVED] Unable to connect GitHub repo to Meteor Cloud

I want to try out Meteor Cloud, but I can’t connect a repo. When the GitHub window appears, I choose an org, then I choose the repo I want to give Meteor access to, but it fails to show up in the list on the next screen in the Meteor Clouse Push to Deploy setup.

I tried to make a new GitHub account just for the specific repo that I have in my GitHub org. I added that user to a team that is admin of the repo. I can’t get it to connect.

I see Meteor Cloud is “installed” in the repo though:

The only view I can get to in Meteor Cloud is this:

I think this needs testing…

Is there any way to use Meteor Cloud other than Push to Deploy?

EDIT: I see the meteor deploy docks after searching. It would be great for this resource to be linked to from Meteor Cloud directly to make it easy.

Push to Deploy is a very recent addition to Meteor Cloud, having been added only days ago. meteor deploy has been the standard way for years now, so that should work without any issues. Do check it out, Meteor Cloud has received some sweet upgrades over the past few years like automatic scaling.

Hi, please open a ticket at support@meteor.com with your account details so we can help you.

We have many clients using it without problems, maybe you found an edge case or you have unusual permissions in your GitHub.

We use it ourselves to deploy our apps as well. :wink:

Meteor Cloud is looking good (first time trying it). meteor deploy works for now, and I’ve scripted it.

I don’t think I have any strange settings in GitHub. I leave everything with defaults except for branch protection rules for pull requests including running GitHub Actions. Really that’s it.

Here’s a video of what I see:

The same thing happened to me today. I found this message in the websocket, not sure if it’s related.

{
  "msg": "result",
  "id": "5",
  "result": {
    "errors": [
      {
        "message": "Method \"collection.aggregate()\" accepts at most two arguments",
        "locations": [],
        "path": [
          "pushToDeployConfigurationRepositories"
        ]
      }
    ],
    "data": {
      "pushToDeployConfigurationRepositories": null
    }
  }
}

Hi @pbya, can you please open a ticket at support@meteor.com with your account details? So we can help you from there.

No one else has issues with this? I just tried again today with an org repo, and same issue. Just try to choose any repo from an org, not personal, and it should mess up.

I’d prefer to solve this in the open (here, not email) as long as we don’t post sensitive info here. I’m working with an open source repo, so it shouldn’t be a problem.

Hey @trusktr, we can try to solve it from here, no problem. Using the support email is usually quicker and sometimes we need sensitive info.

So, I just tested adding a new repository from a new org and it worked. I recorded a video just in case it helps, but I think you did the same as me.

Could you go to your GitHub account in an URL like this https://github.com/organizations/[YOUR_ORG]/settings/installations and check if Meteor Cloud App is installed? You can follow this page. There you can check if the permission is correct and the right repository is selected.

If it doesn’t look right, or even looks right, could you remove it and try the process again?

Could you also send us which email/username you use on Galaxy? So we can try to find something in our logs.

cc @vitorflores

1 Like

Hey @fredmaiaarantes, I deleted the app from the org in GitHub, tried again (yeah, same as in your video) and this time it worked, I was able to get to the screen to select all the options (container size, etc). Maybe it was recently fixed, or else its an intermittent thing.

I’ll report back with a video in case it doesn’t work again for the next one.

1 Like

I’m glad it worked! :slight_smile: