[SOLVED]Unable to update to latest version of meteor


#1

MACLTUS66482:esmerlin-config m_712199$ meteor list
accounts-base 1.2.14* A user account system
dburles:collection-helpers 1.1.0 Transform your collections with helpers that you define
dburles:mongo-collection-instances 0.3.5 Access your Mongo instances
ecmascript 0.5.9* Compiler plugin that supports ES2015+ in all .js files
es5-shim 4.6.15* Shims and polyfills to improve ECMAScript 5 support
ground:db 2.0.0-rc.7* Ground Meteor.Collections offline
http 1.2.9* Make HTTP calls to remote servers
jquery 1.11.10* Manipulate the DOM using CSS selectors
matb33:collection-hooks 0.8.4 Extends Mongo.Collection with before/after hooks for insert/update/remove/find/findOne
meteor-base 1.0.4* Packages that every Meteor app needs
mobile-experience 1.0.4* Packages for a great mobile user experience
mongo 1.1.14+ Adaptor for using MongoDB and Minimongo over DDP
poetic:accounts-apple-connect 0.0.1+
poetic:apple-es-db-adapter 0.0.1+
poetic:apple-es-db-logger 0.0.1+
poetic:meteor-react-guard 2.3.0 Guard your react app against unlogged in users and on-going subscriptions
react-meteor-data 0.2.9* React mixin for reactively tracking Meteor data
reactive-var 1.0.11 Reactive variable
service-configuration 1.0.11 Manage the configuration for third-party services
shell-server 0.2.1* Server-side component of the meteor shell command.
standard-minifier-css 1.3.2* Standard css minifier used with Meteor apps by default.
standard-minifier-js 1.2.1* Standard javascript minifiers used with Meteor apps by default.
static-html 1.1.13* Define static page content in .html files
themeteorchef:bert 2.1.1* A client side, multi-style alerts system for Meteor.
tracker 1.1.1* Dependency tracker to allow reactive callbacks

  • New versions of these packages are available! Run ‘meteor update’ to try to update those packages to their latest versions. If your packages cannot be updated further, try typing meteor add <package>@<newVersion> to
    see more information.
  • These packages are built locally from source.

Here iam trying to update, receiving the below error

MACLTUS66482:esmerlin-config m_712199$ meteor update
=> Errors while initializing project:

While selecting package versions:
error: No version of mongo satisfies all constraints: @1.5.0, @=1.1.14, @~1.5.0
Constraints on package “mongo”:

  • mongo@1.5.0 <- top level
  • mongo@=1.1.14 <- top level
  • mongo@~1.5.0 <- top level
  • mongo@1.4.2 <- autoupdate 1.4.0 <- hot-code-push 1.0.4 <- meteor-base 1.4.0
  • mongo@1.1.14 <- service-configuration 1.0.11
  • mongo@1.3.0 <- accounts-base 1.4.2
  • mongo@1.0.6 <- dburles:mongo-collection-instances 0.1.3
  • mongo@1.0.4 <- matb33:collection-hooks 0.7.5
  • mongo@1.1.12 <- poetic:apple-es-db-adapter 0.0.1

I am seeing this error, need urgent help on this.

Thanks
Sai


#2

It looks like there’s a mongo constraint on poetic:apple-es-db-adapter (there may be others). You could try removing that and see if it updates. Alternatively, try updating with the --allow-incompatible-update flag, but that may introduce other issues.

Make sure you have a commit at a working version, so you can roll back easily.

Edit: I see you resolved this in a double-posting of the error. It would be helpful if you didn’t double-post, or at least edit the title with [SOLVED] to avoid wasting time.