[ Solved ] Updating Meteor (from 2.5.1)

Has anyone stumbled on this:

=> Errors while upgrading packages:           
While selecting package versions:
error: Package names can only contain lowercase ASCII alphanumerics, dash, dot, or colon, not "–".

Stumped… Any help appreciated.

Can you post your list of meteor packages?

Hmm, this is weird since this verification was added in 2014.

Maybe you have new local packages?

As @minhna said, the full list would be helpful, probably the versions file as well.

We could also improve this error message to include the packageName. If you want just run Meteor from a checkout including the packageName in the error message :wink:

Solved… Although not sure what the cause was. Just started a new dev env from git and all is now working… Well, need to go get my dev db folder from Time Machine :wink:

Sorry, but cannot replicate the issue. My apologies to waste your time…

1 Like

I am running into this issue as well as I update an old project into Meteor 1.9 I hit this error. There are no new packages added to the package list. I searched the entire codebase for the offending character and it is not in any package names.

@dsyko Maybe you have a wrong package name in your meteor cache? Try removing it (.meteor/local in your project, and I think ~/.meteor/packages ) and let meteor tool download/build the packages again.

Thanks! I was able to solve it. I’m not sure 100% what did it, but a mix of following this advice to delete .mete/local and also changing the update command from meteor update -version 1.9 to NODE_TLS_REJECT_UNAUTHORIZED=0 meteor update --release 1.9 got it to work.