[Solved] Upgrade to Meteor 1.5.1: Error: Cannot find module '../core-js/symbol/iterator'


#1

Just updated my Meteor 1.3 app to 1.5.1 But now I am getting this error:

W20170716-23:23:17.404(2)? (STDERR) Error: Cannot find module '../core-js/symbol/iterator'
W20170716-23:23:17.405(2)? (STDERR)     at makeMissingError (packages/modules-runtime.js:221:12)
W20170716-23:23:17.405(2)? (STDERR)     at require (packages/modules-runtime.js:231:19)
W20170716-23:23:17.405(2)? (STDERR)     at meteorInstall.node_modules.babel-runtime.helpers.typeof.js (packages/modules.js:775:17)
W20170716-23:23:17.405(2)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:333:9)
W20170716-23:23:17.406(2)? (STDERR)     at require (packages/modules-runtime.js:228:16)
W20170716-23:23:17.406(2)? (STDERR)     at meteorInstall.node_modules.meteor.ddp-client.livedata_connection.js (/Users/waldgeist/Documents/Development/htdocs/aiddogs/webapp/.meteor/local/build/programs/server/packages/ddp-client.js:596:16)
W20170716-23:23:17.406(2)? (STDERR)     at fileEvaluate (packages/modules-runtime.js:333:9)
W20170716-23:23:17.406(2)? (STDERR)     at require (packages/modules-runtime.js:228:16)
W20170716-23:23:17.407(2)? (STDERR)     at /Users/waldgeist/Documents/Development/htdocs/aiddogs/webapp/.meteor/local/build/programs/server/packages/ddp-client.js:2378:1
W20170716-23:23:17.407(2)? (STDERR)     at /Users/waldgeist/Documents/Development/htdocs/aiddogs/webapp/.meteor/local/build/programs/server/packages/ddp-client.js:2390:3

I found this forum thread, but adding babel-runtime as a dependency didn’t help:


#2

Solved by finding this issue. Why isn’t it mentioned in the 1.4 upgrade guide that babel-runtime has to be added to the npm dependencies? https://github.com/meteor/meteor/issues/7833


#3

That was a prerequisite for 1.4.2.1, so I guess it’s just assumed by now.