[SOLVED] Where is the REAL Meteor server public directory?


#1

Hi, everyone,

This might be a dumb question, but here goes: when deploying to an Ubuntu server on Digital Ocean, which directory is the root directory of a Meteor project? When locating, I get the following list:

root@host# locate 808-mixtapes-logo-v4.png
/home/808mix/bundle/programs/web.browser/app/img/808-mixtapes-logo-v4.png
/home/808mix/bundle/programs/web.cordova/app/img/808-mixtapes-logo-v4.png
/opt/808mix/current/bundle/programs/web.browser/app/img/808-mixtapes-logo-v4.png
/opt/808mix/last/bundle/programs/web.browser/app/img/808-mixtapes-logo-v4.png
/opt/808mix/last/bundle/programs/web.cordova/app/img/808-mixtapes-logo-v4.png

Here’s the kicker: I don’t see what happened to my public folder—it’s nowhere to be found!—and when I drop a test image into these app folders (all of them, because there are 5 for some reason), it is inaccessible via the Web. I’ve checked permissions and ownership, and they match the other public assets, so why can’t is see the test file?

So I would surmise that app/ serves as the public directory on the server, since that’s where the content of my public dir was when I uploaded. But that’s clearly not the case, because adding static assets to it only gives me 404 not found errors when I try to navigate to what I think should be their URLs. The images I deployed with the app serve up just fine, though.

I’m running Meteor on a droplet on DigitalOcean, and would like to host my media files in the public directory there. There are many GBs of these files, so I would rather not re-upload them every time I update the app. I had hoped to just copy these files into the public folder, but it doesn’t seem to exist. Tons of Googling and looking around these forums hasn’t helped. What am I supposed to do?


#2

Just create a public folder in your Meteor project’s directory and place the assets you want visible there :).


#3

Thanks @dranithix. :slight_smile: But the thing is, I do have a public directory in the Meteor project root dir. I would place the assets there, but they are huge files that I don’t want to include in the build. That’s why I would like to find a place where Meteor can serve them from the droplet on DigitalOcean, but IDK how ¯_(ツ)_/¯

edit: I’m just going to host the media files on a separate subdomain. It’ll make life easier not just now but probably when I redeploy as well. Thanks again, @dranithix, for the reply. Marking this as solved, though I still have a bit of confusion about how the build/deployment system actually works.