Strange error when booting on server

Hi everyone .
I’m going to set up a completely raw personal server
I get this error when I run the production version on the server.
All requirements are also installed and the node version is compatible
And even when I try to start with mup, I get this error.

1 Like

Are you sure your production bundle is built for the correct architecture?

@paulishca i tested both for the Linux architecture and without setting the architecture.
There is the same error
I tested on Ubuntu 18 and 20

More accurate picture

Invalid ELF header
I usually get that type of message when I deploy to AWS Lambda and by mistake I send the code bundle I built with my OSX.

check this out:

@paulishca Is there a solution?
I want to run it on Ubuntu and use mongodb internally.
I do not know exactly what you mean by wrong architecture

@paulishca Exactly what command do I have to execute to make the production

What MUP plugin are you using?

I did not use any additional plugins. This is my mup file:

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: '19x.10x.xx.2xx',
      username: 'root',
      // pem: './path/to/pem'
      password: 'xxx'
      // or neither for authenticate from ssh-agent

  app: {
    // TODO: change app name and path
    name: 'app',
    path: '../',

    servers: {
      one: {},

    buildOptions: {
      serverOnly: true,

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'http://localhost:3000',
      MONGO_URL: 'mongodb://mongodb/meteor',
      MONGO_OPLOG_URL: 'mongodb://mongodb/local',

    docker: {
      // abernix/meteord:node-12-base works with Meteor 1.9 - 1.10
      // If you are using a different version of Meteor,
      // refer to the docs for the correct image to use.
      image: 'zodern/meteor',

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true

  mongo: {
    version: '4.4',
    servers: {
      one: {}

  // (Optional)
  // Use the proxy to setup ssl or to route requests to the correct
  // app when there are several apps

  // proxy: {
  //   domains: ',',

  //   ssl: {
  //     // Enable Let's Encrypt
  //     letsEncryptEmail: ''
  //   }
  // }

Ok, I never used MUP without a plugin, I only used it to deploy to AWS EBS. But I suspect that you would have to run a docker on your machine with an image and deploy using that docker:

I don’t think it has much to do with mup, because I get this error when I manually configure it and try to start it.

Where did you build your production bundle. Did you build it on that server or on your local machine?

I built it with meteor build and uploaded it to the server .

meteor build F:/Meteor-Build/ --server-only

I also tested by adding this command, but it had the same error

--architecture os.linux.x86_64

I bought.And I installed and launched Node and mongo myself.

Ok, so you don’t build it with the same architecture on which you deploy :). If I did that on my station I would have a bundle resulted from my OSX which I would deploy on ubuntu.
‘–architecture os.linux.x86_64’ is meaningless in your case because you don’t have the context/architecture to use to build. This is why you have to do it from inside a docker that runs an Ubuntu image, as described in MUP. The problem is you don’t follow the MUP documentation.

@paulishca I realized exactly that you did not, suppose I do not use mup, then what is the solution how to build my project

I’ve used this guide in the past for new setups —

1 Like

You can check this thread Deploying to AWS with Meteor 1.3.5 still using MUP . I had written some steps to deploy meteor app and it is still valid as of now though some parts have changed. You will find similar ones from other contributors as well.

1 Like