Susy import problem

Meteor 1.2

@import “{meta:susy}/susy”; doesn’t work

it shows this error:

C:/Ruby193/bin/scss.bat --no-cache --update fileName.scss:fileName.css
error fileName.scss (Line 1: File to import not found or unreadable: {meta:susy}/susy.
Load paths:

Does anyone else had this problem

From the error it looks like the meta:susy package wasn’t added properly. Have you tried removing it (meteor remove meta:susy) and re-adding it (meteor add meta:susy)?

tried it… same result… tried to add foundation package(sass), same thing when try @import same stuff

Maybe as a test create a brand new meteor project, and just add (in the listed order)

meteor add fourseven:scss
meteor add meta:susy

Then try your import. That should work although from your error message it looks like you’re using Windows; I’ve verified this works on OS X but I’m not sure about Windows.

nop, doesn’t work… maybe the problem is ruby, I’m reading this and it says this uses libsass maybe the ruby is the problem. I don’t know why he goes for ruby

Quite possibly - I just removed the meta:susy package from a test meteor app, and I see the following error:

 While processing files with fourseven:scss (for target web.browser):
 /test.scss: Scss compiler error: File to import: {meta:susy}/susy not found
 in file: /Users/hwillson/Desktop/meteor/forums-15532/{}/test.scss

So very similar to the error message you’re seeing, albeit for OS X. So it really looks like either the package didn’t install properly, or something is off with the load paths. Either way I’d recommend opening a ticket with the author (who appears to be quite good at closing issues so you might get a quick turnaround). Good luck!