Testing in Meteor and Windows issues

This issue has been open for a while and, unfortunately, it doesn’t look it’s getting much traction. It’s still labeled as can't-reproduce, even though it’s been reported by myriad Windows users. I’ve encountered this issue on fresh Meteor reinstalls as well as brand new Windows machines.

Is there a more consistent workaround other than having to run the testing process as administrator? That basically kills running your tests in self-hosted CI or even simple Git hooks. You wouldn’t be able to really do that anyway because spacejam doesn’t seem to work on Windows either :frowning:

This really is a big issue, and it’s a shame that it’s not getting any attention because practicalmeteor: mocha is basically the only properly Meteor-supported test runner since Velocity shut down. So far, most of other test runners I’ve tried out would require an unreasonable amount of configuration and special setup for the Meteor environment.

Overall, I’m sorry to say that testing has been, by far, my worst experience with Meteor. I’ve migrated testing frameworks several times over the last couple years I’ve worked with Meteor. The platform would greatly benefit from supporting a larger ecosystem of testing tools so that people aren’t funneled into something that just doesn’t work for everyone and doesn’t perform as well, compared to the competition.

On that note, has anyone had luck testing Meteor apps with other test runners such as Jest, without hacking the hell out of it?