Testing on CI runner times out or hangs for no good reason


#1

I’m at my wit’s end with CIs and Meteor. I have tried every CI service under the sun, and they all fail in some way or another. Either it is too many open files, out of memory issues, or just timeouts.

I ended up spinning up my own gitlab runner with 16gig RAM, which is enough, and I’m getting through my server side mocha tests in 10 minutes, but after that it just hangs, cpu idles and build times out.

I’m using meteortesting:mocha with nightmare to run client tests, and all of this runs just fine locally within 1 minute, including building the app, but in CI with a sever with better specs than my desktop, it just takes SO friggin long.

Anyone else have the same problem, or have overcome them?

TEST_BROWSER_DRIVER=nightmare TOOL_NODE_FLAGS='--max_old_space_size=8192' meteor test --once --driver-package meteortesting:mocha --port 3200

gitlab-ci.yml

image: hubroedu/meteor-runner:latest

services:
  - mongo

cache:
  paths:
    - "app/node_modules"
    - "~/.npm"
    - "~/.meteor"
    - "~/meteor"

before_script:
  - cd app
  - meteor npm install


stages:
  - test


# Run Spec Tests
spec_tests:
  stage: test
  script:
    - meteor npm run ci-unit-test