This project uses Meteor 1.4.2, which isn't available on Windows


#1

Every time I run “meteor” command after install 1.4.2 on Windows 10 64-bit, I get this error:

This project uses Meteor 1.4.2, which isn’t available on Windows. To work with this app on all supported
platforms, use meteor update --release METEOR@1.4.2 to pin this app to the newest Windows-compatible release.

I tried running this command:

meteor update --release METEOR@1.4.2

Still get the same error message.


#2

A few questions:

  • Have you installed Meteor on this computer before?

  • What shell are you using? (e.g. PowerShell, Command Prompt, Ubuntu Bash)

  • If you open Windows Explorer and go to %LocalAppData%\.meteor\packages\meteor-tool\, what folders do you see?

  • Do you have any environment variable set which might be preventing the Meteor catalog from downloading? (e.g. METEOR_OFFLINE_CATALOG)? In Command Prompt, you can just type set to see what you have in your environment. The method in other shells will vary.


#3

Thanks for replying. I fixed everything by just uninstalling my old Meteor and re-installing Metor 1.4.2. Sorry, should have done this in the first place.