Trouble Running App on heroku with Horse buildpack


#1

Using https://github.com/AdmitHub/meteor-buildpack-horse to put my app up on heroku. Running Meteor 1.3.2.4

It looks like its building just fine:

Though when I hit the server url, i get
There is no route for the path: /

What could i be missing here? Works great locally.

Any thoughts?
Thanks!


#2

Hey, I was getting similar issues when following a few tutorials. However I foun the solution, and I wrote an article on how to deploy to Heroku with the new release of Meteor 1.3. You might wanna check it out: https://medium.com/@gautham.gg/deploy-a-meteor-1-3-application-to-heroku-cda1f68ca20a#.on7al5t2v


#3

@gg2001 Thanks for your response. Unfortunately I’ve done all that it’s still not working. Deploying is not the issue. It’s that something isn’t getting started properly or included once it’s there.

I’m using the mantra architecture, wondering if somehow files are getting included as they should.


#4

Exact same issue here with Mantra, ever solve it??


#5

@Cam
Whoops my bad, totally forgot to respond to this thread. Yep fixed it! :slight_smile:
In my case it was an error with bootstrap that was causing the hold up on the javascript side. It seemed like a nominal issue, so I overlooked it, I also would see while running my local instance but didn’t seam to affect things… I’d look at the javascript console for errors and see about resolving then. If your getting a white screen like me it’s probably the issue.