Trying to update from meteor version - can't reach package servers - how can we update to a newer meteor version? -fixed-

Local update hangs while downloading the first package:

Unable to update package catalog (are you offline?)

If you are using Meteor behind a proxy, set HTTP_PROXY and HTTPS_PROXY environment variables or see this page for more details:

=> Errors while initializing project:

While loading fourseven:scss@4.9.0...:
error: Command failed:
/Users/stargazer/.meteor/packages/meteor-tool/.2.4.0_1.1uzjveu.4vfj++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm rebuild
Cannot download "":

HTTP error 404 Not Found

Hint: If is not accessible in your location
try setting a proxy via HTTP_PROXY, e.g.

Remote build seems to fail too:

=> Errors while initializing project:

While downloading autoupdate@1.4.1...:
error: certificate has expired

While downloading babel-runtime@1.2.4_1...:
error: certificate has expired

While downloading blaze-tools@1.0.10...:
error: certificate has expired

While downloading caching-html-compiler@1.1.3...:
error: certificate has expired

While downloading ddp-client@2.3.3...:
error: certificate has expired

While downloading ecmascript-runtime-client@0.7.2...:
error: certificate has expired

While downloading ecmascript-runtime-server@0.7.1...:
error: certificate has expired

While downloading fourseven:scss@4.9.0...:
error: certificate has expired


A colleague of mine in a different location has the same issue.

A newer project (2.2-ish) can update its package catalog?

Hi @DanielDornhardt, we are currently analyzing this.
In the meanwhile, for updating to a newer Meteor version, can you try to append this env var before your meteor update command?

1 Like

Hi - thank you @renanccastro .

I didn’t try that, but I manually updated the .meteor/release - file to 2.4 & then let the project meteor run and also meteor update. Fortunately it was just a pretty small project so no big issues, except for having to rm -rf .meteor/local/db because the DB it has been updated since 1.7.x apparently.

But yes, your fix might just have been what the doctor would have ordered.

So there is an incompatibility between the older meteor versions & the current meteor package servers. Noted.

I comment this for posterity & for everyone having similar issues in the future.

Thank you very much & your thing might have helped the same probably.

Thank you & have a nice day / night!

@renanccastro / @DanielDornhardt i’m having exactly the same issue but not trying to update the project, but actually for me what happened is that the build on my server ( and consequently my continuous deploy ) is broken because of this issue.

We’re not running meteor 2 in production, we’re still on 1.x and now it completely broken our pipeline.

Hi @whatever , I think the meteor / atmosphere auth has changed somehow?

I think if you plop NODE_TLS_REJECT_UNAUTHORIZED=0 before your node command which launches your server (of before the meteor command) it should mitigate the issue for now.

I’m also facing the same issue. I ran the following command, couldn’t afford to update to the latest version so I’m just updating the patch.

NODE_TLS_REJECT_UNAUTHORIZED=0 meteor update --patch

It gives me the following warning

(node:7469) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0' makes TLS connections and HTTPS requests insecure by disabling certificate verification.
(Use `node --trace-warnings ...` to show where the warning was created)

and then fails with the following error

=> Errors while initializing project:

While selecting package versions:
error: No version of accounts-password satisfies all constraints: @1.5.1, @~2.1.0
Constraints on package "accounts-password":
* accounts-password@1.5.1 <- top level
* accounts-password@~2.1.0 <- top level

No version of accounts-base satisfies all constraints: @1.4.2, @~2.1.0
Constraints on package "accounts-base":
* accounts-base@1.4.2 <- top level
* accounts-base@~2.1.0 <- top level
* accounts-base@2.1.0 <- accounts-oauth 1.4.0
* accounts-base@2.1.0 <- service-configuration 1.2.0 <- acemtp:accounts-slack 1.0.0
* accounts-base@1.0.0 <- acemtp:accounts-slack 1.0.0
* accounts-base@1.7.1 || 2.0.0 <- alanning:roles 3.4.0
* accounts-base@1.0.0 <- ian:accounts-ui-bootstrap-3 1.0.0
* accounts-base@2.0.0 <- accounts-github 1.5.0

No version of email satisfies all constraints: @1.2.3, @~2.2.0
Constraints on package "email":
* email@1.2.3 <- top level
* email@~2.2.0 <- top level
* email@1.0.7 <- montiapm:agent 2.31.0

I’m able to run the project without updating it by adding NODE_TLS_REJECT_UNAUTHORIZED prior to the meteor command.


NODE_TLS_REJECT_UNAUTHORIZED=0 meteor --settings settings.json

@distalx yeah, that’s a different issue, incompatible packages, it’s not the same as the TLS error.


I was trying to update my meteor project to the newest version. Meteor insisted that I had to set the HTTP_PROXY and HTTPS_PROXY variables, because I was behind a proxy, which was true.

Those variables were set from the beginning and always working. So there was a new problem and meteor, because of that, could not update itself. As suggested above, I just exec this command before meteor update:

(just have to use Set before the command because I was on Windows)

And everything worked fine afterwards. Thanks for having this solution at hand. By the way, it would be interesting to know if this is going to be fixed and when.

Thanks and bye …

The real solution is to uninstall and install nvm, node and npm. I was able to fix this.